summaryrefslogtreecommitdiff
path: root/python-certauth.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-certauth.spec')
-rw-r--r--python-certauth.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-certauth.spec b/python-certauth.spec
new file mode 100644
index 0000000..cca7da3
--- /dev/null
+++ b/python-certauth.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-certauth
+Version: 1.3.0
+Release: 1
+Summary: Simple Certificate Authority for MITM proxies
+License: MIT
+URL: https://github.com/ikreymer/certauth
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5c/ff/48bdb93555bf93708100be50622ba6ff93d7026e9e172b9e8ab92c2ae8f1/certauth-1.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyopenssl
+Requires: python3-tldextract
+
+%description
+This package provides a small library, built on top of ``pyOpenSSL``, which allows for creating a custom certificate authority certificate,
+and genereating on-demand dynamic host certs using that CA certificate.
+It is most useful for use with a man-in-the-middle HTTPS proxy, for example, for recording or replaying web content.
+Trusting the CA created by this tool should be used with caution in a controlled setting to avoid security risks.
+
+%package -n python3-certauth
+Summary: Simple Certificate Authority for MITM proxies
+Provides: python-certauth
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-certauth
+This package provides a small library, built on top of ``pyOpenSSL``, which allows for creating a custom certificate authority certificate,
+and genereating on-demand dynamic host certs using that CA certificate.
+It is most useful for use with a man-in-the-middle HTTPS proxy, for example, for recording or replaying web content.
+Trusting the CA created by this tool should be used with caution in a controlled setting to avoid security risks.
+
+%package help
+Summary: Development documents and examples for certauth
+Provides: python3-certauth-doc
+%description help
+This package provides a small library, built on top of ``pyOpenSSL``, which allows for creating a custom certificate authority certificate,
+and genereating on-demand dynamic host certs using that CA certificate.
+It is most useful for use with a man-in-the-middle HTTPS proxy, for example, for recording or replaying web content.
+Trusting the CA created by this tool should be used with caution in a controlled setting to avoid security risks.
+
+%prep
+%autosetup -n certauth-1.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-certauth -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
+- Package Spec generated