summaryrefslogtreecommitdiff
path: root/python-certbuilder.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-certbuilder.spec')
-rw-r--r--python-certbuilder.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-certbuilder.spec b/python-certbuilder.spec
new file mode 100644
index 0000000..74d5c6c
--- /dev/null
+++ b/python-certbuilder.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-certbuilder
+Version: 0.14.2
+Release: 1
+Summary: Creates and signs X.509 certificates
+License: MIT
+URL: https://github.com/wbond/certbuilder
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/98/72/3ae0fabde5716b271a1cc773650ccd53c5a5edb3bd00e9b8b8570da59cc1/certbuilder-0.14.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-asn1crypto
+Requires: python3-oscrypto
+
+%description
+Docs for this project are maintained at https://github.com/wbond/certbuilder#readme.
+
+%package -n python3-certbuilder
+Summary: Creates and signs X.509 certificates
+Provides: python-certbuilder
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-certbuilder
+Docs for this project are maintained at https://github.com/wbond/certbuilder#readme.
+
+%package help
+Summary: Development documents and examples for certbuilder
+Provides: python3-certbuilder-doc
+%description help
+Docs for this project are maintained at https://github.com/wbond/certbuilder#readme.
+
+%prep
+%autosetup -n certbuilder-0.14.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-certbuilder -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.14.2-1
+- Package Spec generated