summaryrefslogtreecommitdiff
path: root/python-channels-demultiplexer.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 07:14:58 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 07:14:58 +0000
commit17b0a8b9297ce305eceab9145c24b6ec62e70805 (patch)
tree95c980a51682384b6fb64740fa4843c0c157cb08 /python-channels-demultiplexer.spec
parent8665f1c6a86557171eeef493b6fc4165834cd9fe (diff)
automatic import of python-channels-demultiplexer
Diffstat (limited to 'python-channels-demultiplexer.spec')
-rw-r--r--python-channels-demultiplexer.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/python-channels-demultiplexer.spec b/python-channels-demultiplexer.spec
new file mode 100644
index 0000000..713192a
--- /dev/null
+++ b/python-channels-demultiplexer.spec
@@ -0,0 +1,74 @@
+%global _empty_manifest_terminate_build 0
+Name: python-channels-demultiplexer
+Version: 2.2.0
+Release: 1
+Summary: Demultiplexer for Django Channels
+License: MIT
+URL: https://github.com/csdenboer/channels-demultiplexer
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/89/cb/9e616e9cef864138aace3b3b8c6d30366ab8676cc3f610f08329f46df9fc/channels-demultiplexer-2.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-channels
+Requires: python3-django-appconf
+
+%description
+(De)multiplexer for Django Channels 3 (and 2)
+
+%package -n python3-channels-demultiplexer
+Summary: Demultiplexer for Django Channels
+Provides: python-channels-demultiplexer
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-channels-demultiplexer
+(De)multiplexer for Django Channels 3 (and 2)
+
+%package help
+Summary: Development documents and examples for channels-demultiplexer
+Provides: python3-channels-demultiplexer-doc
+%description help
+(De)multiplexer for Django Channels 3 (and 2)
+
+%prep
+%autosetup -n channels-demultiplexer-2.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-channels-demultiplexer -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 2.2.0-1
+- Package Spec generated