summaryrefslogtreecommitdiff
path: root/python-checkqc.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 02:45:49 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 02:45:49 +0000
commit44450e76e8ab066f5d82e064653f3f6019e00865 (patch)
treee74370f816adfd98934409f011379ee666ac6210 /python-checkqc.spec
parentb6b38dd36398b0b17279598806c398aa1183f995 (diff)
automatic import of python-checkqc
Diffstat (limited to 'python-checkqc.spec')
-rw-r--r--python-checkqc.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-checkqc.spec b/python-checkqc.spec
new file mode 100644
index 0000000..f1298ad
--- /dev/null
+++ b/python-checkqc.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-checkQC
+Version: 3.7.0
+Release: 1
+Summary: A simple program to parse Illumina NGS data and check it for quality criteria.
+License: GPLv3
+URL: https://www.github.com/Molmed/checkQC
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/51/22aa3e231d7f228ea574024b854f6e3058c7e923ed154098fc813b313fc2/checkQC-3.7.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-click
+Requires: python3-PyYAML
+Requires: python3-interop
+Requires: python3-xmltodict
+Requires: python3-tornado
+Requires: python3-sample-sheet
+
+%description
+A simple program to parse Illumina NGS data and check it for quality criteria.
+
+
+%package -n python3-checkQC
+Summary: A simple program to parse Illumina NGS data and check it for quality criteria.
+Provides: python-checkQC
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-checkQC
+A simple program to parse Illumina NGS data and check it for quality criteria.
+
+
+%package help
+Summary: Development documents and examples for checkQC
+Provides: python3-checkQC-doc
+%description help
+A simple program to parse Illumina NGS data and check it for quality criteria.
+
+
+%prep
+%autosetup -n checkQC-3.7.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-checkQC -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 3.7.0-1
+- Package Spec generated