summaryrefslogtreecommitdiff
path: root/python-chess-tuning-tools.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 05:59:37 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 05:59:37 +0000
commit33ac958084a9f0d22a55636b2847ec6c4a898647 (patch)
tree550e63d4b95c33aba5dd63d245093589ef9e2fd6 /python-chess-tuning-tools.spec
parenta8db34153114268e14457326e270a39b590e4596 (diff)
automatic import of python-chess-tuning-tools
Diffstat (limited to 'python-chess-tuning-tools.spec')
-rw-r--r--python-chess-tuning-tools.spec94
1 files changed, 94 insertions, 0 deletions
diff --git a/python-chess-tuning-tools.spec b/python-chess-tuning-tools.spec
new file mode 100644
index 0000000..1d2aae9
--- /dev/null
+++ b/python-chess-tuning-tools.spec
@@ -0,0 +1,94 @@
+%global _empty_manifest_terminate_build 0
+Name: python-chess-tuning-tools
+Version: 0.9.3
+Release: 1
+Summary: A collection of tools for local and distributed tuning of chess engines.
+License: Apache-2.0
+URL: https://github.com/kiudee/chess-tuning-tools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/af/e8/d78c3d0e4123d3f3bea889001c0bdfff8f131b212f73dfae3edc509f382f/chess-tuning-tools-0.9.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-bask
+Requires: python3-Click
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-scikit-optimize
+Requires: python3-atomicwrites
+Requires: python3-scikit-learn
+Requires: python3-dill
+Requires: python3-importlib_metadata
+Requires: python3-joblib
+Requires: python3-psycopg2
+Requires: python3-sqlalchemy
+Requires: python3-pandas
+Requires: python3-Sphinx
+Requires: python3-sphinx-book-theme
+Requires: python3-myst-nb
+
+%description
+* Optimization of chess engines using state-of-the-art `Bayesian optimization <https://github.com/kiudee/bayes-skopt>`_.
+* Support for automatic visualization of the optimization landscape.
+* Scoring matches using a Bayesian-pentanomial model for paired openings.
+
+%package -n python3-chess-tuning-tools
+Summary: A collection of tools for local and distributed tuning of chess engines.
+Provides: python-chess-tuning-tools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-chess-tuning-tools
+* Optimization of chess engines using state-of-the-art `Bayesian optimization <https://github.com/kiudee/bayes-skopt>`_.
+* Support for automatic visualization of the optimization landscape.
+* Scoring matches using a Bayesian-pentanomial model for paired openings.
+
+%package help
+Summary: Development documents and examples for chess-tuning-tools
+Provides: python3-chess-tuning-tools-doc
+%description help
+* Optimization of chess engines using state-of-the-art `Bayesian optimization <https://github.com/kiudee/bayes-skopt>`_.
+* Support for automatic visualization of the optimization landscape.
+* Scoring matches using a Bayesian-pentanomial model for paired openings.
+
+%prep
+%autosetup -n chess-tuning-tools-0.9.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-chess-tuning-tools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.3-1
+- Package Spec generated