summaryrefslogtreecommitdiff
path: root/python-civics-cdf-validator.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-08 08:09:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-08 08:09:57 +0000
commitb09975b30cabc1f589696c0d623255a553d8bb61 (patch)
treed0ec5d77d79f145c8a25790ad5c7596dda267b77 /python-civics-cdf-validator.spec
parent595a5230d7a9b8b153606fb27d09e1b9164c1b34 (diff)
automatic import of python-civics-cdf-validatoropeneuler20.03
Diffstat (limited to 'python-civics-cdf-validator.spec')
-rw-r--r--python-civics-cdf-validator.spec16
1 files changed, 8 insertions, 8 deletions
diff --git a/python-civics-cdf-validator.spec b/python-civics-cdf-validator.spec
index 952ad46..05c38ac 100644
--- a/python-civics-cdf-validator.spec
+++ b/python-civics-cdf-validator.spec
@@ -5,7 +5,7 @@ Release: 1
Summary: Checks if an election feed follows best practices
License: Apache License
URL: https://github.com/google/civics_cdf_validator
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c7/e4/e8822a990746b8ad4cf6b5d216811b9cce133ca57caec528781ca860589c/civics_cdf_validator-1.33.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/c7/e4/e8822a990746b8ad4cf6b5d216811b9cce133ca57caec528781ca860589c/civics_cdf_validator-1.33.tar.gz
BuildArch: noarch
Requires: python3-lxml
@@ -38,7 +38,7 @@ civics_cdf_validator is a script that checks if an election data feed follows be
%prep
-%autosetup -n civics-cdf-validator-1.33
+%autosetup -n civics_cdf_validator-1.33
%build
%py3_build
@@ -52,20 +52,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -78,5 +78,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 1.33-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 1.33-1
- Package Spec generated