summaryrefslogtreecommitdiff
path: root/python-cjio.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 05:25:58 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 05:25:58 +0000
commit78ec2e30bec2467a7854573e07d0ce55cd7d80ae (patch)
treeaed3db66886bc9c6a7746d8d02b77c9bd4a76af8 /python-cjio.spec
parent5b0e690c7e33954c74c02eb9c51264395939ab32 (diff)
automatic import of python-cjio
Diffstat (limited to 'python-cjio.spec')
-rw-r--r--python-cjio.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-cjio.spec b/python-cjio.spec
new file mode 100644
index 0000000..cbe4a70
--- /dev/null
+++ b/python-cjio.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cjio
+Version: 0.8.1
+Release: 1
+Summary: CLI to process and manipulate CityJSON files
+License: MIT
+URL: https://github.com/cityjson/cjio
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/19/f0/1c45a729d2260d9098b4c5133efec90330b85c8113332595ecffd37df0cb/cjio-0.8.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-Click
+Requires: python3-pytest
+Requires: python3-bump2version
+Requires: python3-pandas
+Requires: python3-mapbox-earcut
+Requires: python3-triangle
+Requires: python3-pyproj
+Requires: python3-cjvalpy
+
+%description
+|License: MIT| |image1|
+Python CLI to process and manipulate `CityJSON <http://www.cityjson.org>`_ files.
+The different operators can be chained to perform several processing operations in one step, the
+CityJSON model goes through them and different versions of the CityJSON model can be saved as files along the pipeline.
+
+%package -n python3-cjio
+Summary: CLI to process and manipulate CityJSON files
+Provides: python-cjio
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cjio
+|License: MIT| |image1|
+Python CLI to process and manipulate `CityJSON <http://www.cityjson.org>`_ files.
+The different operators can be chained to perform several processing operations in one step, the
+CityJSON model goes through them and different versions of the CityJSON model can be saved as files along the pipeline.
+
+%package help
+Summary: Development documents and examples for cjio
+Provides: python3-cjio-doc
+%description help
+|License: MIT| |image1|
+Python CLI to process and manipulate `CityJSON <http://www.cityjson.org>`_ files.
+The different operators can be chained to perform several processing operations in one step, the
+CityJSON model goes through them and different versions of the CityJSON model can be saved as files along the pipeline.
+
+%prep
+%autosetup -n cjio-0.8.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cjio -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.1-1
+- Package Spec generated