summaryrefslogtreecommitdiff
path: root/python-ckwrap.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 03:50:12 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 03:50:12 +0000
commitea178dae04c8452948709ab372e0cf9edbfbdd76 (patch)
treeaa610a19e328da9073ebca8f0250068ee122ea3b /python-ckwrap.spec
parent54d829beacf44f475cd320538c8c52551cf6eda7 (diff)
automatic import of python-ckwrap
Diffstat (limited to 'python-ckwrap.spec')
-rw-r--r--python-ckwrap.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-ckwrap.spec b/python-ckwrap.spec
new file mode 100644
index 0000000..509bb50
--- /dev/null
+++ b/python-ckwrap.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ckwrap
+Version: 0.1.10
+Release: 1
+Summary: Python wrapper for Ckmeans.1d.dp, 4.3.4.
+License: LGPL
+URL: https://github.com/djdt/ckwrap
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9e/fe/0473792a1cb9ebc91d50702b06af66b6002186fac8cf26af659ccec0f827/ckwrap-0.1.10.tar.gz
+
+Requires: python3-numpy
+Requires: python3-Cython
+
+%description
+# ckwrap
+
+Python wrapper for the R package Ckmeans.1d.dp (https://cran.r-project.org/package=Ckmeans.1d.dp).
+Ckmeans.1d.dp produces fast, optimal, and reproducible weighted univariate clustering by dynamic programming.
+
+Based off of https://github.com/rocketrip/ckmeans/.
+
+
+## Installation
+
+To install via pip:
+
+```pip install ckwrap```
+
+
+
+
+%package -n python3-ckwrap
+Summary: Python wrapper for Ckmeans.1d.dp, 4.3.4.
+Provides: python-ckwrap
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-ckwrap
+# ckwrap
+
+Python wrapper for the R package Ckmeans.1d.dp (https://cran.r-project.org/package=Ckmeans.1d.dp).
+Ckmeans.1d.dp produces fast, optimal, and reproducible weighted univariate clustering by dynamic programming.
+
+Based off of https://github.com/rocketrip/ckmeans/.
+
+
+## Installation
+
+To install via pip:
+
+```pip install ckwrap```
+
+
+
+
+%package help
+Summary: Development documents and examples for ckwrap
+Provides: python3-ckwrap-doc
+%description help
+# ckwrap
+
+Python wrapper for the R package Ckmeans.1d.dp (https://cran.r-project.org/package=Ckmeans.1d.dp).
+Ckmeans.1d.dp produces fast, optimal, and reproducible weighted univariate clustering by dynamic programming.
+
+Based off of https://github.com/rocketrip/ckmeans/.
+
+
+## Installation
+
+To install via pip:
+
+```pip install ckwrap```
+
+
+
+
+%prep
+%autosetup -n ckwrap-0.1.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ckwrap -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.10-1
+- Package Spec generated