summaryrefslogtreecommitdiff
path: root/python-classproperties.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-classproperties.spec')
-rw-r--r--python-classproperties.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/python-classproperties.spec b/python-classproperties.spec
new file mode 100644
index 0000000..b18968a
--- /dev/null
+++ b/python-classproperties.spec
@@ -0,0 +1,114 @@
+%global _empty_manifest_terminate_build 0
+Name: python-classproperties
+Version: 0.2.0
+Release: 1
+Summary: property for class methods
+License: MIT
+URL: https://github.com/dpep/pyclassproperties
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ee/cf/a540ef6bbf6df3192dcb6549a8c84034f5937c5393cefce49f7dec29fead/classproperties-0.2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+#### Install
+```pip install classproperties```
+#### Usage
+```
+from classproperties import classproperty
+class Foo:
+ @classproperty
+ def prop():
+ return 'hi there'
+ @classproperty
+ def other(cls):
+ return 'also works'
+Foo.prop
+Foo.other
+```
+
+%package -n python3-classproperties
+Summary: property for class methods
+Provides: python-classproperties
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-classproperties
+#### Install
+```pip install classproperties```
+#### Usage
+```
+from classproperties import classproperty
+class Foo:
+ @classproperty
+ def prop():
+ return 'hi there'
+ @classproperty
+ def other(cls):
+ return 'also works'
+Foo.prop
+Foo.other
+```
+
+%package help
+Summary: Development documents and examples for classproperties
+Provides: python3-classproperties-doc
+%description help
+#### Install
+```pip install classproperties```
+#### Usage
+```
+from classproperties import classproperty
+class Foo:
+ @classproperty
+ def prop():
+ return 'hi there'
+ @classproperty
+ def other(cls):
+ return 'also works'
+Foo.prop
+Foo.other
+```
+
+%prep
+%autosetup -n classproperties-0.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-classproperties -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
+- Package Spec generated