summaryrefslogtreecommitdiff
path: root/python-clingo-dl.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-clingo-dl.spec')
-rw-r--r--python-clingo-dl.spec92
1 files changed, 92 insertions, 0 deletions
diff --git a/python-clingo-dl.spec b/python-clingo-dl.spec
new file mode 100644
index 0000000..a31f798
--- /dev/null
+++ b/python-clingo-dl.spec
@@ -0,0 +1,92 @@
+%global _empty_manifest_terminate_build 0
+Name: python-clingo-dl
+Version: 1.4.0
+Release: 1
+Summary: CFFI-based bindings to the clingo-dl solver.
+License: MIT
+URL: https://github.com/potassco/clingo-dl
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/43/e0e1e326ec5163f953c259a7fb60dfc7c4fb8050615c72e8bae3d27963df/clingo-dl-1.4.0.tar.gz
+
+
+%description
+This package allows for adding the clingo-dl propagator as a
+theory to clingo.
+
+It can also be used as a clingo-dl solver running:
+
+ python -m clingodl CLINGODL_ARGUMENTS
+
+
+%package -n python3-clingo-dl
+Summary: CFFI-based bindings to the clingo-dl solver.
+Provides: python-clingo-dl
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-clingo-dl
+This package allows for adding the clingo-dl propagator as a
+theory to clingo.
+
+It can also be used as a clingo-dl solver running:
+
+ python -m clingodl CLINGODL_ARGUMENTS
+
+
+%package help
+Summary: Development documents and examples for clingo-dl
+Provides: python3-clingo-dl-doc
+%description help
+This package allows for adding the clingo-dl propagator as a
+theory to clingo.
+
+It can also be used as a clingo-dl solver running:
+
+ python -m clingodl CLINGODL_ARGUMENTS
+
+
+%prep
+%autosetup -n clingo-dl-1.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-clingo-dl -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.4.0-1
+- Package Spec generated