summaryrefslogtreecommitdiff
path: root/python-cloudformation-cli-python-plugin.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cloudformation-cli-python-plugin.spec')
-rw-r--r--python-cloudformation-cli-python-plugin.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-cloudformation-cli-python-plugin.spec b/python-cloudformation-cli-python-plugin.spec
new file mode 100644
index 0000000..0869799
--- /dev/null
+++ b/python-cloudformation-cli-python-plugin.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cloudformation-cli-python-plugin
+Version: 2.1.7
+Release: 1
+Summary: Python 3.6 and 3.7 language support for the CloudFormation CLI
+License: Apache License 2.0
+URL: https://github.com/aws-cloudformation/aws-cloudformation-rpdk-python-plugin/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/15/db/2cd0f9208191b0cbf284fa8ae0b9914a30cb90979669426c0c0a6101d907/cloudformation-cli-python-plugin-2.1.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-cloudformation-cli
+Requires: python3-types-dataclasses
+
+%description
+```bash
+pip install cloudformation-cli-python-plugin
+```
+
+%package -n python3-cloudformation-cli-python-plugin
+Summary: Python 3.6 and 3.7 language support for the CloudFormation CLI
+Provides: python-cloudformation-cli-python-plugin
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cloudformation-cli-python-plugin
+```bash
+pip install cloudformation-cli-python-plugin
+```
+
+%package help
+Summary: Development documents and examples for cloudformation-cli-python-plugin
+Provides: python3-cloudformation-cli-python-plugin-doc
+%description help
+```bash
+pip install cloudformation-cli-python-plugin
+```
+
+%prep
+%autosetup -n cloudformation-cli-python-plugin-2.1.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cloudformation-cli-python-plugin -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.7-1
+- Package Spec generated