summaryrefslogtreecommitdiff
path: root/python-cmakelintbear.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 04:22:11 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 04:22:11 +0000
commit1d9373412dea1d8822f2f90d7fbcdf36f163957d (patch)
treed7710a45a28c44fa239451f86ac15aa230fe03e5 /python-cmakelintbear.spec
parent671cdde80b1310d9ce2d95ab497c1cb7e37c1df4 (diff)
automatic import of python-cmakelintbear
Diffstat (limited to 'python-cmakelintbear.spec')
-rw-r--r--python-cmakelintbear.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-cmakelintbear.spec b/python-cmakelintbear.spec
new file mode 100644
index 0000000..0385bb7
--- /dev/null
+++ b/python-cmakelintbear.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-CMakeLintBear
+Version: 0.10.0
+Release: 1
+Summary: 'CMakeLintBear' bear for coala (http://coala.rtfd.org/)
+License: AGPL-3.0
+URL: https://pypi.org/project/CMakeLintBear/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5c/91/a4a21193a3f71824ec0ffb19ee8e96ba3f70a6d670b86cf022e59fd8e7ed/CMakeLintBear-0.10.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Check CMake code for syntactical or formatting issues.
+
+ For more information consult <https://github.com/richq/cmake-lint>.
+
+%package -n python3-CMakeLintBear
+Summary: 'CMakeLintBear' bear for coala (http://coala.rtfd.org/)
+Provides: python-CMakeLintBear
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-CMakeLintBear
+Check CMake code for syntactical or formatting issues.
+
+ For more information consult <https://github.com/richq/cmake-lint>.
+
+%package help
+Summary: Development documents and examples for CMakeLintBear
+Provides: python3-CMakeLintBear-doc
+%description help
+Check CMake code for syntactical or formatting issues.
+
+ For more information consult <https://github.com/richq/cmake-lint>.
+
+%prep
+%autosetup -n CMakeLintBear-0.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-CMakeLintBear -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
+- Package Spec generated