summaryrefslogtreecommitdiff
path: root/python-colcon-output.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-colcon-output.spec')
-rw-r--r--python-colcon-output.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-colcon-output.spec b/python-colcon-output.spec
new file mode 100644
index 0000000..627a365
--- /dev/null
+++ b/python-colcon-output.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-colcon-output
+Version: 0.2.13
+Release: 1
+Summary: Extension for colcon to customize the output in various ways.
+License: Apache License, Version 2.0
+URL: https://colcon.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/aa/80685c78aa55457365da5817f8f468d58004f031428568b42c8954276d40/colcon-output-0.2.13.tar.gz
+BuildArch: noarch
+
+Requires: python3-pylint
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-scspell3k
+Requires: python3-colcon-core
+Requires: python3-flake8
+Requires: python3-flake8-blind-except
+Requires: python3-flake8-builtins
+Requires: python3-flake8-class-newline
+Requires: python3-flake8-comprehensions
+Requires: python3-flake8-deprecated
+Requires: python3-flake8-docstrings
+Requires: python3-flake8-import-order
+Requires: python3-flake8-quotes
+Requires: python3-pep8-naming
+
+%description
+An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to customize the output in various ways.
+
+%package -n python3-colcon-output
+Summary: Extension for colcon to customize the output in various ways.
+Provides: python-colcon-output
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-colcon-output
+An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to customize the output in various ways.
+
+%package help
+Summary: Development documents and examples for colcon-output
+Provides: python3-colcon-output-doc
+%description help
+An extension for `colcon-core <https://github.com/colcon/colcon-core>`_ to customize the output in various ways.
+
+%prep
+%autosetup -n colcon-output-0.2.13
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-colcon-output -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.13-1
+- Package Spec generated