summaryrefslogtreecommitdiff
path: root/python-com-enovation.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-com-enovation.spec')
-rw-r--r--python-com-enovation.spec97
1 files changed, 97 insertions, 0 deletions
diff --git a/python-com-enovation.spec b/python-com-enovation.spec
new file mode 100644
index 0000000..bc21f03
--- /dev/null
+++ b/python-com-enovation.spec
@@ -0,0 +1,97 @@
+%global _empty_manifest_terminate_build 0
+Name: python-com-enovation
+Version: 0.0.36
+Release: 1
+Summary: project management toolbox
+License: Other/Proprietary License
+URL: https://jsebastien_Guillard@bitbucket.org/jsebastien_Guillard
+Source0: https://mirrors.aliyun.com/pypi/web/packages/c9/bf/aaca824f8e440a8362c11c7429924ad63c7c26ce3491c2f158d5f60cf33e/com-enovation-0.0.36.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-click
+Requires: python3-scipy
+Requires: python3-enlighten
+Requires: python3-openpyxl
+Requires: python3-xlwt
+Requires: python3-dash
+Requires: python3-dash-bootstrap-components
+Requires: python3-dash-extensions
+Requires: python3-flask-caching
+Requires: python3-jsonschema
+Requires: python3-xlsxwriter
+Requires: python3-xlrd
+
+%description
+# A python tool box
+Our python tool-box is supposed to help professionals in their day-to-day work.
+Everything started when reaching blocking limitations with MS Excel, forcing us to search for alternatives. We learned Python, and started to implement reusable snippets.
+As of 2021, we have a first workable snippet (yet perfectible), and we target to progressively (even-though
+slowly) enrich this tool-box, focusing on "IT project management" related stuff (as a start?).
+
+%package -n python3-com-enovation
+Summary: project management toolbox
+Provides: python-com-enovation
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-com-enovation
+# A python tool box
+Our python tool-box is supposed to help professionals in their day-to-day work.
+Everything started when reaching blocking limitations with MS Excel, forcing us to search for alternatives. We learned Python, and started to implement reusable snippets.
+As of 2021, we have a first workable snippet (yet perfectible), and we target to progressively (even-though
+slowly) enrich this tool-box, focusing on "IT project management" related stuff (as a start?).
+
+%package help
+Summary: Development documents and examples for com-enovation
+Provides: python3-com-enovation-doc
+%description help
+# A python tool box
+Our python tool-box is supposed to help professionals in their day-to-day work.
+Everything started when reaching blocking limitations with MS Excel, forcing us to search for alternatives. We learned Python, and started to implement reusable snippets.
+As of 2021, we have a first workable snippet (yet perfectible), and we target to progressively (even-though
+slowly) enrich this tool-box, focusing on "IT project management" related stuff (as a start?).
+
+%prep
+%autosetup -n com-enovation-0.0.36
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-com-enovation -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri Jun 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.36-1
+- Package Spec generated