summaryrefslogtreecommitdiff
path: root/python-commonpy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-commonpy.spec')
-rw-r--r--python-commonpy.spec98
1 files changed, 98 insertions, 0 deletions
diff --git a/python-commonpy.spec b/python-commonpy.spec
new file mode 100644
index 0000000..059b2f7
--- /dev/null
+++ b/python-commonpy.spec
@@ -0,0 +1,98 @@
+%global _empty_manifest_terminate_build 0
+Name: python-commonpy
+Version: 1.13.0
+Release: 1
+Summary: Assortment of Python helper functions and utility classes
+License: BSD 3-clause
+URL: https://github.com/caltechlibrary/commonpy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6c/09/00e4602ffdf48ee267a700a5ab8a1716853ab98260dec42379af4adf9f00/commonpy-1.13.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-PyYAML
+Requires: python3-boltons
+Requires: python3-dateparser
+Requires: python3-deprecation
+Requires: python3-h2
+Requires: python3-httpx
+Requires: python3-humanize
+Requires: python3-dateutil
+Requires: python3-regex
+Requires: python3-setuptools
+Requires: python3-sidetrack
+Requires: python3-tldextract
+Requires: python3-validator-collection
+Requires: python3-pywin32
+
+%description
+This is a collection of common utility functions and classes that we at the Caltech Library have found useful in our other Python projects.
+[![Latest release](https://img.shields.io/github/v/release/caltechlibrary/commonpy.svg?style=flat-square&color=b44e88&label=Latest%20release)](https://github.com/caltechlibrary/commonpy/releases)
+[![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg?style=flat-square)](https://choosealicense.com/licenses/bsd-3-clause)
+[![Python](https://img.shields.io/badge/Python-3.6+-brightgreen.svg?style=flat-square)](http://shields.io)
+[![PyPI](https://img.shields.io/pypi/v/commonpy.svg?style=flat-square&color=orange&label=PyPI)](https://pypi.org/project/commonpy/)
+
+%package -n python3-commonpy
+Summary: Assortment of Python helper functions and utility classes
+Provides: python-commonpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-commonpy
+This is a collection of common utility functions and classes that we at the Caltech Library have found useful in our other Python projects.
+[![Latest release](https://img.shields.io/github/v/release/caltechlibrary/commonpy.svg?style=flat-square&color=b44e88&label=Latest%20release)](https://github.com/caltechlibrary/commonpy/releases)
+[![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg?style=flat-square)](https://choosealicense.com/licenses/bsd-3-clause)
+[![Python](https://img.shields.io/badge/Python-3.6+-brightgreen.svg?style=flat-square)](http://shields.io)
+[![PyPI](https://img.shields.io/pypi/v/commonpy.svg?style=flat-square&color=orange&label=PyPI)](https://pypi.org/project/commonpy/)
+
+%package help
+Summary: Development documents and examples for commonpy
+Provides: python3-commonpy-doc
+%description help
+This is a collection of common utility functions and classes that we at the Caltech Library have found useful in our other Python projects.
+[![Latest release](https://img.shields.io/github/v/release/caltechlibrary/commonpy.svg?style=flat-square&color=b44e88&label=Latest%20release)](https://github.com/caltechlibrary/commonpy/releases)
+[![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg?style=flat-square)](https://choosealicense.com/licenses/bsd-3-clause)
+[![Python](https://img.shields.io/badge/Python-3.6+-brightgreen.svg?style=flat-square)](http://shields.io)
+[![PyPI](https://img.shields.io/pypi/v/commonpy.svg?style=flat-square&color=orange&label=PyPI)](https://pypi.org/project/commonpy/)
+
+%prep
+%autosetup -n commonpy-1.13.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-commonpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.13.0-1
+- Package Spec generated