%global _empty_manifest_terminate_build 0
Name:		python-compas-tna
Version:	0.2.0
Release:	1
Summary:	COMPAS package for Thrust Network Analysis
License:	MIT
URL:		https://github.com/BlockResearchGroup/compas_tna
Source0:	https://mirrors.aliyun.com/pypi/web/packages/21/b4/2026fa10509ccfa6045e5a42f4902a780b87246cd49ba93bd64ad345ae94/compas_tna-0.2.0.tar.gz
BuildArch:	noarch

Requires:	python3-compas

%description
# compas_tna

[![GitHub - License](https://img.shields.io/github/license/blockresearchgroup/compas_tna.svg)](https://github.com/blockresearchgroup/compas_tna)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/compas-tna.svg)](https://pypi.python.org/project/compas-tna)
[![PyPI - Latest Release](https://img.shields.io/pypi/v/compas-tna.svg)](https://pypi.python.org/project/compas-tna)
[![DOI](https://zenodo.org/badge/113331502.svg)](https://zenodo.org/badge/latestdoi/113331502)

COMPAS package for Thrust Network Analaysis. This package provides the base implementation of TNA. For a RhinoVault-style user interface and workflow, see `compas-RV2`.

## Getting Started

Have a look at the "Getting Started" instructions in the docs: <https://compas-dev.github.io/compas_tna/gettingstarted.html>.

## First Steps

A good place to start exploring TNA through `compas_tna` are the [tutorial](https://compas-dev.github.io/compas_tna/tutorial.html), and the [examples](https://compas-dev.github.io/compas_tna/examples.html).

## Questions and Feedback

For questions and feedback , have a look at the [compas_tna category](https://forum.compas-framework.org/c/compas-tna) of the COMPAS forum.

## Issues

If you run into problems, please file an issue on the [issue tracker](https://github.com/compas-dev/compas_tna/issues). If we don't know it is broken, we can't fix it...

## Contributing

Guidelines for developers are under construction. However, we always accept contributions in the form of Pull Requests.

## License

`compas_tna` is licensed under the MIT License. See [LICENSE](https://github.com/compas-dev/compas_tna/blob/master/LICENSE), for more information.


%package -n python3-compas-tna
Summary:	COMPAS package for Thrust Network Analysis
Provides:	python-compas-tna
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-compas-tna
# compas_tna

[![GitHub - License](https://img.shields.io/github/license/blockresearchgroup/compas_tna.svg)](https://github.com/blockresearchgroup/compas_tna)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/compas-tna.svg)](https://pypi.python.org/project/compas-tna)
[![PyPI - Latest Release](https://img.shields.io/pypi/v/compas-tna.svg)](https://pypi.python.org/project/compas-tna)
[![DOI](https://zenodo.org/badge/113331502.svg)](https://zenodo.org/badge/latestdoi/113331502)

COMPAS package for Thrust Network Analaysis. This package provides the base implementation of TNA. For a RhinoVault-style user interface and workflow, see `compas-RV2`.

## Getting Started

Have a look at the "Getting Started" instructions in the docs: <https://compas-dev.github.io/compas_tna/gettingstarted.html>.

## First Steps

A good place to start exploring TNA through `compas_tna` are the [tutorial](https://compas-dev.github.io/compas_tna/tutorial.html), and the [examples](https://compas-dev.github.io/compas_tna/examples.html).

## Questions and Feedback

For questions and feedback , have a look at the [compas_tna category](https://forum.compas-framework.org/c/compas-tna) of the COMPAS forum.

## Issues

If you run into problems, please file an issue on the [issue tracker](https://github.com/compas-dev/compas_tna/issues). If we don't know it is broken, we can't fix it...

## Contributing

Guidelines for developers are under construction. However, we always accept contributions in the form of Pull Requests.

## License

`compas_tna` is licensed under the MIT License. See [LICENSE](https://github.com/compas-dev/compas_tna/blob/master/LICENSE), for more information.


%package help
Summary:	Development documents and examples for compas-tna
Provides:	python3-compas-tna-doc
%description help
# compas_tna

[![GitHub - License](https://img.shields.io/github/license/blockresearchgroup/compas_tna.svg)](https://github.com/blockresearchgroup/compas_tna)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/compas-tna.svg)](https://pypi.python.org/project/compas-tna)
[![PyPI - Latest Release](https://img.shields.io/pypi/v/compas-tna.svg)](https://pypi.python.org/project/compas-tna)
[![DOI](https://zenodo.org/badge/113331502.svg)](https://zenodo.org/badge/latestdoi/113331502)

COMPAS package for Thrust Network Analaysis. This package provides the base implementation of TNA. For a RhinoVault-style user interface and workflow, see `compas-RV2`.

## Getting Started

Have a look at the "Getting Started" instructions in the docs: <https://compas-dev.github.io/compas_tna/gettingstarted.html>.

## First Steps

A good place to start exploring TNA through `compas_tna` are the [tutorial](https://compas-dev.github.io/compas_tna/tutorial.html), and the [examples](https://compas-dev.github.io/compas_tna/examples.html).

## Questions and Feedback

For questions and feedback , have a look at the [compas_tna category](https://forum.compas-framework.org/c/compas-tna) of the COMPAS forum.

## Issues

If you run into problems, please file an issue on the [issue tracker](https://github.com/compas-dev/compas_tna/issues). If we don't know it is broken, we can't fix it...

## Contributing

Guidelines for developers are under construction. However, we always accept contributions in the form of Pull Requests.

## License

`compas_tna` is licensed under the MIT License. See [LICENSE](https://github.com/compas-dev/compas_tna/blob/master/LICENSE), for more information.


%prep
%autosetup -n compas_tna-0.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-compas-tna -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
- Package Spec generated