summaryrefslogtreecommitdiff
path: root/python-compress-json.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 11:29:27 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 11:29:27 +0000
commitb4d66a2baa3537d9c0dadea660e3c90813858d0b (patch)
treea98eb4cf1cf1242aa0f4c3434b2385b7d8b1f0a8 /python-compress-json.spec
parentfb8850f6e94cb67b1ec797c30a14723f6a90efd1 (diff)
automatic import of python-compress-json
Diffstat (limited to 'python-compress-json.spec')
-rw-r--r--python-compress-json.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-compress-json.spec b/python-compress-json.spec
new file mode 100644
index 0000000..754944c
--- /dev/null
+++ b/python-compress-json.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-compress-json
+Version: 1.0.8
+Release: 1
+Summary: The missing Python utility to read and write large compressed JSONs.
+License: MIT
+URL: https://github.com/LucaCappelletti94/compress_json
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f7/60/83343ff7a3e82d78cdb4f09ed0f3652a11fe814180f984620f1ecb2e4c49/compress_json-1.0.8.tar.gz
+BuildArch: noarch
+
+
+%description
+|pip| |downloads|
+The missing Python utility to read and write large compressed JSONs.
+The library is loosely based on the `compress_pickle <https://github.com/lucianopaz/compress_pickle>`_ library.
+
+%package -n python3-compress-json
+Summary: The missing Python utility to read and write large compressed JSONs.
+Provides: python-compress-json
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-compress-json
+|pip| |downloads|
+The missing Python utility to read and write large compressed JSONs.
+The library is loosely based on the `compress_pickle <https://github.com/lucianopaz/compress_pickle>`_ library.
+
+%package help
+Summary: Development documents and examples for compress-json
+Provides: python3-compress-json-doc
+%description help
+|pip| |downloads|
+The missing Python utility to read and write large compressed JSONs.
+The library is loosely based on the `compress_pickle <https://github.com/lucianopaz/compress_pickle>`_ library.
+
+%prep
+%autosetup -n compress-json-1.0.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-compress-json -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.8-1
+- Package Spec generated