summaryrefslogtreecommitdiff
path: root/python-coveo-itertools.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 10:59:14 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 10:59:14 +0000
commitc25e56560753812cfb8b806cdfe9d355121ff29f (patch)
treeff5ef4e3c15527b6b589ed9b524c06ff6ed8dc15 /python-coveo-itertools.spec
parent59a72bc9d171f69ec6651a392e4332bb8259a178 (diff)
automatic import of python-coveo-itertoolsopeneuler20.03
Diffstat (limited to 'python-coveo-itertools.spec')
-rw-r--r--python-coveo-itertools.spec132
1 files changed, 132 insertions, 0 deletions
diff --git a/python-coveo-itertools.spec b/python-coveo-itertools.spec
new file mode 100644
index 0000000..4e3bf84
--- /dev/null
+++ b/python-coveo-itertools.spec
@@ -0,0 +1,132 @@
+%global _empty_manifest_terminate_build 0
+Name: python-coveo-itertools
+Version: 2.0.5
+Release: 1
+Summary: Collection-related helpers.
+License: Apache-2.0
+URL: https://github.com/coveooss/coveo-python-oss/tree/main/coveo-itertools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dc/85/cf18ca76aa8d54028fa9a996d5e7214a5ef3d8ba5ec818bbde5a7da526c2/coveo_itertools-2.0.5.tar.gz
+BuildArch: noarch
+
+
+%description
+# coveo-itertools
+
+Another spin on iteration goodness.
+
+
+## dict lookup
+
+A one-liner function to retrieve a value from a dictionary:
+
+
+```python
+from typing import Dict, Any
+from coveo_itertools.lookups import dict_lookup
+
+
+example: Dict[str, Any] = {'nested': {'key': {'lookup': True}}}
+
+assert dict_lookup(example, 'nested', 'key', 'lookup') == True
+assert dict_lookup(example, 'not', 'there', default=None) is None
+```
+
+
+%package -n python3-coveo-itertools
+Summary: Collection-related helpers.
+Provides: python-coveo-itertools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-coveo-itertools
+# coveo-itertools
+
+Another spin on iteration goodness.
+
+
+## dict lookup
+
+A one-liner function to retrieve a value from a dictionary:
+
+
+```python
+from typing import Dict, Any
+from coveo_itertools.lookups import dict_lookup
+
+
+example: Dict[str, Any] = {'nested': {'key': {'lookup': True}}}
+
+assert dict_lookup(example, 'nested', 'key', 'lookup') == True
+assert dict_lookup(example, 'not', 'there', default=None) is None
+```
+
+
+%package help
+Summary: Development documents and examples for coveo-itertools
+Provides: python3-coveo-itertools-doc
+%description help
+# coveo-itertools
+
+Another spin on iteration goodness.
+
+
+## dict lookup
+
+A one-liner function to retrieve a value from a dictionary:
+
+
+```python
+from typing import Dict, Any
+from coveo_itertools.lookups import dict_lookup
+
+
+example: Dict[str, Any] = {'nested': {'key': {'lookup': True}}}
+
+assert dict_lookup(example, 'nested', 'key', 'lookup') == True
+assert dict_lookup(example, 'not', 'there', default=None) is None
+```
+
+
+%prep
+%autosetup -n coveo-itertools-2.0.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-coveo-itertools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.5-1
+- Package Spec generated