summaryrefslogtreecommitdiff
path: root/python-crush.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:59:26 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:59:26 +0000
commit659cb620daf4e3585e79a94cc2c4a96f59062b6c (patch)
treece4170502d6078f031984f489a8a8c2b672ad6df /python-crush.spec
parent8e501525a5f278830c65abff5420030b60b89811 (diff)
automatic import of python-crush
Diffstat (limited to 'python-crush.spec')
-rw-r--r--python-crush.spec91
1 files changed, 91 insertions, 0 deletions
diff --git a/python-crush.spec b/python-crush.spec
new file mode 100644
index 0000000..c40c548
--- /dev/null
+++ b/python-crush.spec
@@ -0,0 +1,91 @@
+%global _empty_manifest_terminate_build 0
+Name: python-crush
+Version: 1.0.35
+Release: 1
+Summary: library to control placement in a hierarchy
+License: GNU General Public License v3 or later (GPLv3+)
+URL: http://libcrush.org/main/python-crush
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/7b/2fd699893193eec99cbcf12e16c6199c6f116e71cea17d1c83f3d715757f/crush-1.0.35.tar.gz
+BuildArch: noarch
+
+Requires: python3-appdirs
+Requires: python3-d2to1
+Requires: python3-numpy
+Requires: python3-packaging
+Requires: python3-pandas
+Requires: python3-pbr
+Requires: python3-pyparsing
+Requires: python3-dateutil
+Requires: python3-pytz
+Requires: python3-six
+
+%description
+crush is a library to control placement in a hierarchy
+- Home page : http://http://libcrush.org/main/python-crush
+- Documentation : http://crush.readthedocs.org/
+- PyPi : https://pypi.python.org/pypi/crush
+
+%package -n python3-crush
+Summary: library to control placement in a hierarchy
+Provides: python-crush
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-crush
+crush is a library to control placement in a hierarchy
+- Home page : http://http://libcrush.org/main/python-crush
+- Documentation : http://crush.readthedocs.org/
+- PyPi : https://pypi.python.org/pypi/crush
+
+%package help
+Summary: Development documents and examples for crush
+Provides: python3-crush-doc
+%description help
+crush is a library to control placement in a hierarchy
+- Home page : http://http://libcrush.org/main/python-crush
+- Documentation : http://crush.readthedocs.org/
+- PyPi : https://pypi.python.org/pypi/crush
+
+%prep
+%autosetup -n crush-1.0.35
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-crush -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.35-1
+- Package Spec generated