summaryrefslogtreecommitdiff
path: root/python-cryolo.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-cryolo.spec')
-rw-r--r--python-cryolo.spec132
1 files changed, 132 insertions, 0 deletions
diff --git a/python-cryolo.spec b/python-cryolo.spec
new file mode 100644
index 0000000..36bd7ad
--- /dev/null
+++ b/python-cryolo.spec
@@ -0,0 +1,132 @@
+%global _empty_manifest_terminate_build 0
+Name: python-cryolo
+Version: 1.9.3
+Release: 1
+Summary: Picking procedure for cryo em single particle analysis
+License: Other/Proprietary License (all rights reserved)
+URL: https://cryolo.readthedocs.io/en/stable/index.html
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ba/86/9ca239e2abbaf425a3526d74c883917feaa710b9d2277e57d8230d00619e/cryolo-1.9.3.tar.gz
+BuildArch: noarch
+
+
+%description
+
+[![pipeline status](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/badges/master/pipeline.svg)](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/-/commits/predict3d)
+[![coverage report](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/badges/master/coverage.svg)](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/-/commits/predict3d)
+
+# SPHIRE-crYOLO
+
+Deep learning particle picking procedure based on YOLOv2.
+Please see [our website](https://cryolo.readthedocs.io/en/stable/) for more information.
+
+## License
+The license information can be found here:
+
+[EULA license of crYOLO](https://cryolo.readthedocs.io/en/stable/other/license.html)
+
+## Paper
+If you use crYOLO, please cite
+
+Wagner, T. et al. SPHIRE-crYOLO is a fast and accurate fully automated particle picker for cryo-EM. Communications Biology 2, (2019).
+
+ https://doi.org/10.1038/s42003-019-0437-z
+
+
+%package -n python3-cryolo
+Summary: Picking procedure for cryo em single particle analysis
+Provides: python-cryolo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-cryolo
+
+[![pipeline status](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/badges/master/pipeline.svg)](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/-/commits/predict3d)
+[![coverage report](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/badges/master/coverage.svg)](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/-/commits/predict3d)
+
+# SPHIRE-crYOLO
+
+Deep learning particle picking procedure based on YOLOv2.
+Please see [our website](https://cryolo.readthedocs.io/en/stable/) for more information.
+
+## License
+The license information can be found here:
+
+[EULA license of crYOLO](https://cryolo.readthedocs.io/en/stable/other/license.html)
+
+## Paper
+If you use crYOLO, please cite
+
+Wagner, T. et al. SPHIRE-crYOLO is a fast and accurate fully automated particle picker for cryo-EM. Communications Biology 2, (2019).
+
+ https://doi.org/10.1038/s42003-019-0437-z
+
+
+%package help
+Summary: Development documents and examples for cryolo
+Provides: python3-cryolo-doc
+%description help
+
+[![pipeline status](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/badges/master/pipeline.svg)](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/-/commits/predict3d)
+[![coverage report](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/badges/master/coverage.svg)](https://gitlab.gwdg.de/mpi-dortmund/sphire/cryolo/-/commits/predict3d)
+
+# SPHIRE-crYOLO
+
+Deep learning particle picking procedure based on YOLOv2.
+Please see [our website](https://cryolo.readthedocs.io/en/stable/) for more information.
+
+## License
+The license information can be found here:
+
+[EULA license of crYOLO](https://cryolo.readthedocs.io/en/stable/other/license.html)
+
+## Paper
+If you use crYOLO, please cite
+
+Wagner, T. et al. SPHIRE-crYOLO is a fast and accurate fully automated particle picker for cryo-EM. Communications Biology 2, (2019).
+
+ https://doi.org/10.1038/s42003-019-0437-z
+
+
+%prep
+%autosetup -n cryolo-1.9.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-cryolo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.9.3-1
+- Package Spec generated