summaryrefslogtreecommitdiff
path: root/python-csslintbear.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 04:46:00 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 04:46:00 +0000
commit9408c2d287bb38ef4f782d27037ba0da8d16d676 (patch)
tree328a4b3d1418b04cdbbdc6d421dda61db776b72e /python-csslintbear.spec
parentbf867a90cae1910478b8b8b3cdc3d37bbcdef5c0 (diff)
automatic import of python-csslintbear
Diffstat (limited to 'python-csslintbear.spec')
-rw-r--r--python-csslintbear.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-csslintbear.spec b/python-csslintbear.spec
new file mode 100644
index 0000000..8f26424
--- /dev/null
+++ b/python-csslintbear.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-CSSLintBear
+Version: 0.10.0
+Release: 1
+Summary: 'CSSLintBear' bear for coala (http://coala.rtfd.org/)
+License: AGPL-3.0
+URL: https://pypi.org/project/CSSLintBear/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/03/afc52dcef32f5aa61dd994affcc846183e2ac3cae5542082e2831e861fe0/CSSLintBear-0.10.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Check code for syntactical or semantical problems that might lead to
+ problems or inefficiencies.
+
+%package -n python3-CSSLintBear
+Summary: 'CSSLintBear' bear for coala (http://coala.rtfd.org/)
+Provides: python-CSSLintBear
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-CSSLintBear
+Check code for syntactical or semantical problems that might lead to
+ problems or inefficiencies.
+
+%package help
+Summary: Development documents and examples for CSSLintBear
+Provides: python3-CSSLintBear-doc
+%description help
+Check code for syntactical or semantical problems that might lead to
+ problems or inefficiencies.
+
+%prep
+%autosetup -n CSSLintBear-0.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-CSSLintBear -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
+- Package Spec generated