summaryrefslogtreecommitdiff
path: root/python-dask-kubernetes.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dask-kubernetes.spec')
-rw-r--r--python-dask-kubernetes.spec79
1 files changed, 79 insertions, 0 deletions
diff --git a/python-dask-kubernetes.spec b/python-dask-kubernetes.spec
new file mode 100644
index 0000000..7c34cb5
--- /dev/null
+++ b/python-dask-kubernetes.spec
@@ -0,0 +1,79 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dask-kubernetes
+Version: 2023.3.2
+Release: 1
+Summary: Native Kubernetes integration for Dask
+License: BSD
+URL: https://github.com/dask/dask-kubernetes
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/da/98/9ce9c978bff64823afaef3600f9d0f32c5f34b4c95aa70516b30ea0badaa/dask-kubernetes-2023.3.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-dask
+Requires: python3-distributed
+Requires: python3-kubernetes
+Requires: python3-kubernetes-asyncio
+Requires: python3-kopf
+Requires: python3-pykube-ng
+Requires: python3-rich
+
+%description
+Native Kubernetes integration for Dask.
+
+%package -n python3-dask-kubernetes
+Summary: Native Kubernetes integration for Dask
+Provides: python-dask-kubernetes
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dask-kubernetes
+Native Kubernetes integration for Dask.
+
+%package help
+Summary: Development documents and examples for dask-kubernetes
+Provides: python3-dask-kubernetes-doc
+%description help
+Native Kubernetes integration for Dask.
+
+%prep
+%autosetup -n dask-kubernetes-2023.3.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dask-kubernetes -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.3.2-1
+- Package Spec generated