summaryrefslogtreecommitdiff
path: root/python-datacode.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:13:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:13:32 +0000
commit1b54801e92994ac50a4bc49ac01a01dd2fc9f325 (patch)
tree1316350e99da5c00e6ea909263182c9f2f21469b /python-datacode.spec
parentcaa06d643ed84c89f5daf23be66f663764bed803 (diff)
automatic import of python-datacode
Diffstat (limited to 'python-datacode.spec')
-rw-r--r--python-datacode.spec196
1 files changed, 196 insertions, 0 deletions
diff --git a/python-datacode.spec b/python-datacode.spec
new file mode 100644
index 0000000..8a4f925
--- /dev/null
+++ b/python-datacode.spec
@@ -0,0 +1,196 @@
+%global _empty_manifest_terminate_build 0
+Name: python-datacode
+Version: 0.20.8
+Release: 1
+Summary: High-level tools to analyze, summarize, and transform data
+License: MIT
+URL: https://github.com/nickderobertis/data-code
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/91/fc/bb7b906cecd1ca1967eb6b579d16a360548aa8b3c10961e5277a24ed942d/datacode-0.20.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-pd-utils
+Requires: python3-matplotlib
+Requires: python3-regtools
+Requires: python3-pyexlatex
+Requires: python3-sympy
+Requires: python3-IPython
+Requires: python3-mixins
+Requires: python3-semopy
+Requires: python3-sklearn
+Requires: python3-typing-extensions
+Requires: python3-graphviz
+Requires: python3-deepdiff
+
+%description
+
+[![](https://codecov.io/gh/nickderobertis/data-code/branch/master/graph/badge.svg)](https://codecov.io/gh/nickderobertis/data-code)
+
+# data-code
+
+## Overview
+
+Data pipelines for humans. Work with variables, sources, and pipelines rather than raw data. Also includes high-level tools to analyze, summarize, and transform data.
+
+## Getting Started
+
+Install `datacode`:
+
+```
+pip install datacode
+```
+
+A simple example:
+
+```python
+import datacode
+
+# Do something with datacode
+```
+
+## Links
+
+See the
+[documentation here.](
+https://nickderobertis.github.io/data-code/
+)
+
+## Author
+
+Created by Nick DeRobertis. MIT License.
+
+
+
+
+%package -n python3-datacode
+Summary: High-level tools to analyze, summarize, and transform data
+Provides: python-datacode
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-datacode
+
+[![](https://codecov.io/gh/nickderobertis/data-code/branch/master/graph/badge.svg)](https://codecov.io/gh/nickderobertis/data-code)
+
+# data-code
+
+## Overview
+
+Data pipelines for humans. Work with variables, sources, and pipelines rather than raw data. Also includes high-level tools to analyze, summarize, and transform data.
+
+## Getting Started
+
+Install `datacode`:
+
+```
+pip install datacode
+```
+
+A simple example:
+
+```python
+import datacode
+
+# Do something with datacode
+```
+
+## Links
+
+See the
+[documentation here.](
+https://nickderobertis.github.io/data-code/
+)
+
+## Author
+
+Created by Nick DeRobertis. MIT License.
+
+
+
+
+%package help
+Summary: Development documents and examples for datacode
+Provides: python3-datacode-doc
+%description help
+
+[![](https://codecov.io/gh/nickderobertis/data-code/branch/master/graph/badge.svg)](https://codecov.io/gh/nickderobertis/data-code)
+
+# data-code
+
+## Overview
+
+Data pipelines for humans. Work with variables, sources, and pipelines rather than raw data. Also includes high-level tools to analyze, summarize, and transform data.
+
+## Getting Started
+
+Install `datacode`:
+
+```
+pip install datacode
+```
+
+A simple example:
+
+```python
+import datacode
+
+# Do something with datacode
+```
+
+## Links
+
+See the
+[documentation here.](
+https://nickderobertis.github.io/data-code/
+)
+
+## Author
+
+Created by Nick DeRobertis. MIT License.
+
+
+
+
+%prep
+%autosetup -n datacode-0.20.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-datacode -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.20.8-1
+- Package Spec generated