summaryrefslogtreecommitdiff
path: root/python-dathost.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 07:18:13 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 07:18:13 +0000
commit0f86d547db9ed9b9970a7668aaf178466ca32c4c (patch)
tree2f5ccbbb06623e3809e59fb07546d3489bcfd1ce /python-dathost.spec
parent7d19577fab944240449823c0cebddd1518bf22d7 (diff)
automatic import of python-dathost
Diffstat (limited to 'python-dathost.spec')
-rw-r--r--python-dathost.spec144
1 files changed, 144 insertions, 0 deletions
diff --git a/python-dathost.spec b/python-dathost.spec
new file mode 100644
index 0000000..ebae448
--- /dev/null
+++ b/python-dathost.spec
@@ -0,0 +1,144 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dathost
+Version: 1.0.2
+Release: 1
+Summary: Asynchronous / Synchronous dathost API wrapper.
+License: GPL v3
+URL: https://dathost.readthedocs.io/en/latest/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e2/77/1cab63ae1e9d374cdd81110150563305358d5f28e573bf62c60935e81117/dathost-1.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-httpx
+Requires: python3-asynctest
+Requires: python3-aiofiles
+Requires: python3-sphinxcontrib-trio
+Requires: python3-steam
+Requires: python3-sphinx-material
+
+%description
+## Welcome to Dathost’s unofficial python wrapper!
+This is a unofficial asynchronous & synchronous wrapper for Dathost’s API.
+
+### Features:
+- Full API coverage.
+- Asynchronous & synchronous support.
+- Easy to use with an object oriented design.
+- 100% test coverage.
+
+### Install
+- Pip: ``pip3 install dathost``
+- Git: ``pip3 install git+https://github.com/WardPearce/dathost.git``
+
+
+### Documentation
+[Documentation](https://dathost.readthedocs.io/en/latest/)
+
+
+### Thanks to
+- [Encode for creating HTTPX](https://www.python-httpx.org/)
+
+
+
+
+%package -n python3-dathost
+Summary: Asynchronous / Synchronous dathost API wrapper.
+Provides: python-dathost
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dathost
+## Welcome to Dathost’s unofficial python wrapper!
+This is a unofficial asynchronous & synchronous wrapper for Dathost’s API.
+
+### Features:
+- Full API coverage.
+- Asynchronous & synchronous support.
+- Easy to use with an object oriented design.
+- 100% test coverage.
+
+### Install
+- Pip: ``pip3 install dathost``
+- Git: ``pip3 install git+https://github.com/WardPearce/dathost.git``
+
+
+### Documentation
+[Documentation](https://dathost.readthedocs.io/en/latest/)
+
+
+### Thanks to
+- [Encode for creating HTTPX](https://www.python-httpx.org/)
+
+
+
+
+%package help
+Summary: Development documents and examples for dathost
+Provides: python3-dathost-doc
+%description help
+## Welcome to Dathost’s unofficial python wrapper!
+This is a unofficial asynchronous & synchronous wrapper for Dathost’s API.
+
+### Features:
+- Full API coverage.
+- Asynchronous & synchronous support.
+- Easy to use with an object oriented design.
+- 100% test coverage.
+
+### Install
+- Pip: ``pip3 install dathost``
+- Git: ``pip3 install git+https://github.com/WardPearce/dathost.git``
+
+
+### Documentation
+[Documentation](https://dathost.readthedocs.io/en/latest/)
+
+
+### Thanks to
+- [Encode for creating HTTPX](https://www.python-httpx.org/)
+
+
+
+
+%prep
+%autosetup -n dathost-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dathost -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated