summaryrefslogtreecommitdiff
path: root/python-dbutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dbutils.spec')
-rw-r--r--python-dbutils.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-dbutils.spec b/python-dbutils.spec
new file mode 100644
index 0000000..2a7350a
--- /dev/null
+++ b/python-dbutils.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-DBUtils
+Version: 3.0.2
+Release: 1
+Summary: Database connections for multi-threaded environments.
+License: MIT License
+URL: https://webwareforpython.github.io/DBUtils/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/78/88/1926d786612bd9270ab8ea734c680dd99410aa18d75750008e8b996ae366/DBUtils-3.0.2.tar.gz
+BuildArch: noarch
+
+
+%description
+DBUtils is a suite of tools providing solid, persistent and pooled connections
+to a database that can be used in all kinds of multi-threaded environments.
+The suite supports DB-API 2 compliant database interfaces
+and the classic PyGreSQL interface.
+The current version 3.0.2 of DBUtils supports Python versions 3.6 to 3.10.
+**Please have a look at the [changelog](https://webwareforpython.github.io/DBUtils/changelog.html), because there were some breaking changes in version 2.0.**
+The DBUtils home page can be found at https://webwareforpython.github.io/DBUtils/
+
+%package -n python3-DBUtils
+Summary: Database connections for multi-threaded environments.
+Provides: python-DBUtils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-DBUtils
+DBUtils is a suite of tools providing solid, persistent and pooled connections
+to a database that can be used in all kinds of multi-threaded environments.
+The suite supports DB-API 2 compliant database interfaces
+and the classic PyGreSQL interface.
+The current version 3.0.2 of DBUtils supports Python versions 3.6 to 3.10.
+**Please have a look at the [changelog](https://webwareforpython.github.io/DBUtils/changelog.html), because there were some breaking changes in version 2.0.**
+The DBUtils home page can be found at https://webwareforpython.github.io/DBUtils/
+
+%package help
+Summary: Development documents and examples for DBUtils
+Provides: python3-DBUtils-doc
+%description help
+DBUtils is a suite of tools providing solid, persistent and pooled connections
+to a database that can be used in all kinds of multi-threaded environments.
+The suite supports DB-API 2 compliant database interfaces
+and the classic PyGreSQL interface.
+The current version 3.0.2 of DBUtils supports Python versions 3.6 to 3.10.
+**Please have a look at the [changelog](https://webwareforpython.github.io/DBUtils/changelog.html), because there were some breaking changes in version 2.0.**
+The DBUtils home page can be found at https://webwareforpython.github.io/DBUtils/
+
+%prep
+%autosetup -n DBUtils-3.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-DBUtils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.2-1
+- Package Spec generated