summaryrefslogtreecommitdiff
path: root/python-deduplipy.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-08 13:59:15 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-08 13:59:15 +0000
commit2a27741023249b305e0b64ebf14b8e3e43f43476 (patch)
treea299ad64ca9146e0a69c3407515e682bfd6ba547 /python-deduplipy.spec
parent4ded57da09468cf36184e2a9223569077d64105b (diff)
automatic import of python-deduplipyopeneuler20.03
Diffstat (limited to 'python-deduplipy.spec')
-rw-r--r--python-deduplipy.spec24
1 files changed, 12 insertions, 12 deletions
diff --git a/python-deduplipy.spec b/python-deduplipy.spec
index e6cf211..31548f7 100644
--- a/python-deduplipy.spec
+++ b/python-deduplipy.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-DedupliPy
-Version: 0.7.10
+Version: 0.8
Release: 1
Summary: End-to-end deduplication solution
License: MIT License
URL: https://github.com/fritshermans/deduplipy
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/b1/72cc8af1c02eba9a072ea7e7eeb5177610970909b767e928e58f66ffe50d/DedupliPy-0.7.10.tar.gz
+Source0: https://mirrors.aliyun.com/pypi/web/packages/4c/4c/f984eeac34c0d15cb07820d3abfdc84845aaac56363881c16b21d554e80b/DedupliPy-0.8.tar.gz
BuildArch: noarch
Requires: python3-pandas
@@ -15,7 +15,7 @@ Requires: python3-scikit-learn
Requires: python3-networkx
Requires: python3-Levenshtein
Requires: python3-thefuzz
-Requires: python3-modAL
+Requires: python3-modAL-python
Requires: python3-openpyxl
Requires: python3-pytest
Requires: python3-fancyimpute
@@ -27,7 +27,7 @@ Requires: python3-scikit-learn
Requires: python3-networkx
Requires: python3-Levenshtein
Requires: python3-thefuzz
-Requires: python3-modAL
+Requires: python3-modAL-python
Requires: python3-openpyxl
Requires: python3-pytest
Requires: python3-fancyimpute
@@ -39,7 +39,7 @@ Requires: python3-scikit-learn
Requires: python3-networkx
Requires: python3-Levenshtein
Requires: python3-thefuzz
-Requires: python3-modAL
+Requires: python3-modAL-python
Requires: python3-openpyxl
Requires: python3-pytest
Requires: python3-fancyimpute
@@ -318,7 +318,7 @@ result = myDedupliPy.predict(df)
%prep
-%autosetup -n DedupliPy-0.7.10
+%autosetup -n DedupliPy-0.8
%build
%py3_build
@@ -332,20 +332,20 @@ if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
- find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
- find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
- find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
- find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
- find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
@@ -358,5 +358,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue May 30 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.10-1
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8-1
- Package Spec generated