summaryrefslogtreecommitdiff
path: root/python-deemon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-deemon.spec')
-rw-r--r--python-deemon.spec318
1 files changed, 318 insertions, 0 deletions
diff --git a/python-deemon.spec b/python-deemon.spec
new file mode 100644
index 0000000..0ceb38a
--- /dev/null
+++ b/python-deemon.spec
@@ -0,0 +1,318 @@
+%global _empty_manifest_terminate_build 0
+Name: python-deemon
+Version: 2.18.5
+Release: 1
+Summary: Monitor new releases by a specified list of artists and auto download using the deemix library
+License: GPL3
+URL: https://github.com/digitalec/deemon
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/22/53/76cba7947dc3df4b2a151ab052f7feff882f969cde4fccccc26b0ba8953c/deemon-2.18.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-deemix
+Requires: python3-packaging
+Requires: python3-requests
+Requires: python3-click
+Requires: python3-setuptools
+Requires: python3-PlexAPI
+Requires: python3-tqdm
+Requires: python3-mutagen
+Requires: python3-Unidecode
+
+%description
+<img src="deemon/assets/images/deemon.png" alt="deemon" width="300">
+
+[About](#about) | [Installation](#installation) | [Docker](#docker) | [Documentation](https://digitalec.github.io/deemon) | [Support](#support)
+
+![PyPI](https://img.shields.io/pypi/v/deemon?style=for-the-badge)
+![Downloads](https://img.shields.io/pypi/dm/deemon?style=for-the-badge)
+![GitHub last release](https://img.shields.io/github/release-date/digitalec/deemon?style=for-the-badge)
+
+![GitHub last commit](https://img.shields.io/github/last-commit/digitalec/deemon?style=for-the-badge)
+![Docker](https://img.shields.io/github/actions/workflow/status/digitalec/deemon/deploy-docker.yml?branch=main&style=for-the-badge&logo=docker)
+
+![Discord](https://img.shields.io/discord/831356172464160838?style=for-the-badge&logo=discord)
+[![Donate](https://img.shields.io/badge/Donate-PayPal-blue?style=for-the-badge&logo=paypal)](https://paypal.me/digitalec)
+
+
+### About
+deemon is a command line tool written in Python that monitors artists for new releases, provides email notifications and can also integrate with the deemix library to automatically download new releases.
+
+### Support
+[Open an Issue](https://github.com/digitalec/deemon/issues/new) | [Discord](https://discord.gg/KzNCG2tkvn)
+
+### Installation
+
+#### Using pip
+
+```bash
+$ pip install deemon
+```
+
+#### From source
+```bash
+$ pip install -r requirements.txt
+$ python3 -m deemon
+```
+
+### Docker
+
+Docker support has been added for `amd64`, `arm64` and `armv7` architectures. It is recommended to save your `docker run` command as a script to execute via cron/Task Scheduler.
+
+**Note:** Inside deemon's `config.json`, download_location **must** be set to `/downloads` until I can integrate this myself.
+
+**Example: Refreshing an existing database**
+```
+docker run --name deemon \
+ --rm \
+ -v /path/to/deemon/config:/config \
+ -v /path/to/music:/downloads \
+ -v /path/to/deemix/config:/deemix \
+ ghcr.io/digitalec/deemon:latest \
+ python3 -m deemon refresh
+```
+
+### Installation in a Python Virtual Environment (venv)
+
+If you wish to install deemon and it's dependencies in a sandbox-style environment, I would recommend using venv.
+
+Create a venv and install deemon (you may need to use `python3` and `pip3` depending on your system):
+```commandline
+$ python -m venv venv
+$ source ./venv/bin/activate
+$ pip install deemon
+```
+
+When you are finished, close the terminal or exit our venv:
+```commandline
+$ deactivate
+```
+
+Next time you want to run deemon, activate the venv first:
+```commandline
+$ source ./venv/bin/activate
+$ deemon refresh
+```
+
+If you are moving to venv from the Docker container, be sure to update your cron/Task Scheduler scripts.
+
+### Default Configuration
+If you need to generate a new default configuration, please rename or delete your current `config.json`. The
+configuration will be generated the next time you run deemon.
+
+
+%package -n python3-deemon
+Summary: Monitor new releases by a specified list of artists and auto download using the deemix library
+Provides: python-deemon
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-deemon
+<img src="deemon/assets/images/deemon.png" alt="deemon" width="300">
+
+[About](#about) | [Installation](#installation) | [Docker](#docker) | [Documentation](https://digitalec.github.io/deemon) | [Support](#support)
+
+![PyPI](https://img.shields.io/pypi/v/deemon?style=for-the-badge)
+![Downloads](https://img.shields.io/pypi/dm/deemon?style=for-the-badge)
+![GitHub last release](https://img.shields.io/github/release-date/digitalec/deemon?style=for-the-badge)
+
+![GitHub last commit](https://img.shields.io/github/last-commit/digitalec/deemon?style=for-the-badge)
+![Docker](https://img.shields.io/github/actions/workflow/status/digitalec/deemon/deploy-docker.yml?branch=main&style=for-the-badge&logo=docker)
+
+![Discord](https://img.shields.io/discord/831356172464160838?style=for-the-badge&logo=discord)
+[![Donate](https://img.shields.io/badge/Donate-PayPal-blue?style=for-the-badge&logo=paypal)](https://paypal.me/digitalec)
+
+
+### About
+deemon is a command line tool written in Python that monitors artists for new releases, provides email notifications and can also integrate with the deemix library to automatically download new releases.
+
+### Support
+[Open an Issue](https://github.com/digitalec/deemon/issues/new) | [Discord](https://discord.gg/KzNCG2tkvn)
+
+### Installation
+
+#### Using pip
+
+```bash
+$ pip install deemon
+```
+
+#### From source
+```bash
+$ pip install -r requirements.txt
+$ python3 -m deemon
+```
+
+### Docker
+
+Docker support has been added for `amd64`, `arm64` and `armv7` architectures. It is recommended to save your `docker run` command as a script to execute via cron/Task Scheduler.
+
+**Note:** Inside deemon's `config.json`, download_location **must** be set to `/downloads` until I can integrate this myself.
+
+**Example: Refreshing an existing database**
+```
+docker run --name deemon \
+ --rm \
+ -v /path/to/deemon/config:/config \
+ -v /path/to/music:/downloads \
+ -v /path/to/deemix/config:/deemix \
+ ghcr.io/digitalec/deemon:latest \
+ python3 -m deemon refresh
+```
+
+### Installation in a Python Virtual Environment (venv)
+
+If you wish to install deemon and it's dependencies in a sandbox-style environment, I would recommend using venv.
+
+Create a venv and install deemon (you may need to use `python3` and `pip3` depending on your system):
+```commandline
+$ python -m venv venv
+$ source ./venv/bin/activate
+$ pip install deemon
+```
+
+When you are finished, close the terminal or exit our venv:
+```commandline
+$ deactivate
+```
+
+Next time you want to run deemon, activate the venv first:
+```commandline
+$ source ./venv/bin/activate
+$ deemon refresh
+```
+
+If you are moving to venv from the Docker container, be sure to update your cron/Task Scheduler scripts.
+
+### Default Configuration
+If you need to generate a new default configuration, please rename or delete your current `config.json`. The
+configuration will be generated the next time you run deemon.
+
+
+%package help
+Summary: Development documents and examples for deemon
+Provides: python3-deemon-doc
+%description help
+<img src="deemon/assets/images/deemon.png" alt="deemon" width="300">
+
+[About](#about) | [Installation](#installation) | [Docker](#docker) | [Documentation](https://digitalec.github.io/deemon) | [Support](#support)
+
+![PyPI](https://img.shields.io/pypi/v/deemon?style=for-the-badge)
+![Downloads](https://img.shields.io/pypi/dm/deemon?style=for-the-badge)
+![GitHub last release](https://img.shields.io/github/release-date/digitalec/deemon?style=for-the-badge)
+
+![GitHub last commit](https://img.shields.io/github/last-commit/digitalec/deemon?style=for-the-badge)
+![Docker](https://img.shields.io/github/actions/workflow/status/digitalec/deemon/deploy-docker.yml?branch=main&style=for-the-badge&logo=docker)
+
+![Discord](https://img.shields.io/discord/831356172464160838?style=for-the-badge&logo=discord)
+[![Donate](https://img.shields.io/badge/Donate-PayPal-blue?style=for-the-badge&logo=paypal)](https://paypal.me/digitalec)
+
+
+### About
+deemon is a command line tool written in Python that monitors artists for new releases, provides email notifications and can also integrate with the deemix library to automatically download new releases.
+
+### Support
+[Open an Issue](https://github.com/digitalec/deemon/issues/new) | [Discord](https://discord.gg/KzNCG2tkvn)
+
+### Installation
+
+#### Using pip
+
+```bash
+$ pip install deemon
+```
+
+#### From source
+```bash
+$ pip install -r requirements.txt
+$ python3 -m deemon
+```
+
+### Docker
+
+Docker support has been added for `amd64`, `arm64` and `armv7` architectures. It is recommended to save your `docker run` command as a script to execute via cron/Task Scheduler.
+
+**Note:** Inside deemon's `config.json`, download_location **must** be set to `/downloads` until I can integrate this myself.
+
+**Example: Refreshing an existing database**
+```
+docker run --name deemon \
+ --rm \
+ -v /path/to/deemon/config:/config \
+ -v /path/to/music:/downloads \
+ -v /path/to/deemix/config:/deemix \
+ ghcr.io/digitalec/deemon:latest \
+ python3 -m deemon refresh
+```
+
+### Installation in a Python Virtual Environment (venv)
+
+If you wish to install deemon and it's dependencies in a sandbox-style environment, I would recommend using venv.
+
+Create a venv and install deemon (you may need to use `python3` and `pip3` depending on your system):
+```commandline
+$ python -m venv venv
+$ source ./venv/bin/activate
+$ pip install deemon
+```
+
+When you are finished, close the terminal or exit our venv:
+```commandline
+$ deactivate
+```
+
+Next time you want to run deemon, activate the venv first:
+```commandline
+$ source ./venv/bin/activate
+$ deemon refresh
+```
+
+If you are moving to venv from the Docker container, be sure to update your cron/Task Scheduler scripts.
+
+### Default Configuration
+If you need to generate a new default configuration, please rename or delete your current `config.json`. The
+configuration will be generated the next time you run deemon.
+
+
+%prep
+%autosetup -n deemon-2.18.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-deemon -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.18.5-1
+- Package Spec generated