summaryrefslogtreecommitdiff
path: root/python-deid.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-deid.spec')
-rw-r--r--python-deid.spec192
1 files changed, 192 insertions, 0 deletions
diff --git a/python-deid.spec b/python-deid.spec
new file mode 100644
index 0000000..35b90a1
--- /dev/null
+++ b/python-deid.spec
@@ -0,0 +1,192 @@
+%global _empty_manifest_terminate_build 0
+Name: python-deid
+Version: 0.3.22
+Release: 1
+Summary: best effort deidentify dicom with python and pydicom
+License: LICENSE
+URL: https://github.com/pydicom/deid
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/09/31/67227831745a5217dce959d5327e1a479a9f424ababef27f38c3cf77fe22/deid-0.3.22.tar.gz
+BuildArch: noarch
+
+
+%description
+# Deidentify (deid)
+
+Best effort anonymization for medical images in Python.
+
+[![DOI](https://zenodo.org/badge/94163984.svg)](https://zenodo.org/badge/latestdoi/94163984)
+[![Build Status](https://travis-ci.org/pydicom/deid.svg?branch=master)](https://travis-ci.org/pydicom/deid)
+
+Please see our [Documentation](https://pydicom.github.io/deid/).
+
+These are basic Python based tools for working with medical images and text, specifically for de-identification.
+The cleaning method used here mirrors the one by CTP in that we can identify images based on known
+locations. We are looking for collaborators to develop and validate an OCR cleaning method! Please reach out if you would like to help work on this.
+
+
+## Installation
+
+### Local
+For the stable release, install via pip:
+
+```bash
+pip install deid
+```
+
+For the development version, install from Github:
+
+```bash
+pip install git+git://github.com/pydicom/deid
+```
+
+### Docker
+
+```bash
+docker build -t pydicom/deid .
+docker run pydicom/deid --help
+```
+
+## Issues
+If you have an issue, or want to request a feature, please do so on our [issues board](https://www.github.com/pydicom/deid/issues).
+
+
+
+
+%package -n python3-deid
+Summary: best effort deidentify dicom with python and pydicom
+Provides: python-deid
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-deid
+# Deidentify (deid)
+
+Best effort anonymization for medical images in Python.
+
+[![DOI](https://zenodo.org/badge/94163984.svg)](https://zenodo.org/badge/latestdoi/94163984)
+[![Build Status](https://travis-ci.org/pydicom/deid.svg?branch=master)](https://travis-ci.org/pydicom/deid)
+
+Please see our [Documentation](https://pydicom.github.io/deid/).
+
+These are basic Python based tools for working with medical images and text, specifically for de-identification.
+The cleaning method used here mirrors the one by CTP in that we can identify images based on known
+locations. We are looking for collaborators to develop and validate an OCR cleaning method! Please reach out if you would like to help work on this.
+
+
+## Installation
+
+### Local
+For the stable release, install via pip:
+
+```bash
+pip install deid
+```
+
+For the development version, install from Github:
+
+```bash
+pip install git+git://github.com/pydicom/deid
+```
+
+### Docker
+
+```bash
+docker build -t pydicom/deid .
+docker run pydicom/deid --help
+```
+
+## Issues
+If you have an issue, or want to request a feature, please do so on our [issues board](https://www.github.com/pydicom/deid/issues).
+
+
+
+
+%package help
+Summary: Development documents and examples for deid
+Provides: python3-deid-doc
+%description help
+# Deidentify (deid)
+
+Best effort anonymization for medical images in Python.
+
+[![DOI](https://zenodo.org/badge/94163984.svg)](https://zenodo.org/badge/latestdoi/94163984)
+[![Build Status](https://travis-ci.org/pydicom/deid.svg?branch=master)](https://travis-ci.org/pydicom/deid)
+
+Please see our [Documentation](https://pydicom.github.io/deid/).
+
+These are basic Python based tools for working with medical images and text, specifically for de-identification.
+The cleaning method used here mirrors the one by CTP in that we can identify images based on known
+locations. We are looking for collaborators to develop and validate an OCR cleaning method! Please reach out if you would like to help work on this.
+
+
+## Installation
+
+### Local
+For the stable release, install via pip:
+
+```bash
+pip install deid
+```
+
+For the development version, install from Github:
+
+```bash
+pip install git+git://github.com/pydicom/deid
+```
+
+### Docker
+
+```bash
+docker build -t pydicom/deid .
+docker run pydicom/deid --help
+```
+
+## Issues
+If you have an issue, or want to request a feature, please do so on our [issues board](https://www.github.com/pydicom/deid/issues).
+
+
+
+
+%prep
+%autosetup -n deid-0.3.22
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-deid -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.22-1
+- Package Spec generated