summaryrefslogtreecommitdiff
path: root/python-delegator-py.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 11:38:27 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 11:38:27 +0000
commit2ff3f38fa9ae05a876ee5fed5a0f2379fbd5da9b (patch)
tree0f94965ee454481a8de7010e250c32c61e5800aa /python-delegator-py.spec
parent0c8fc804fb8df4d6543083a974c6b4044e39a885 (diff)
automatic import of python-delegator-py
Diffstat (limited to 'python-delegator-py.spec')
-rw-r--r--python-delegator-py.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-delegator-py.spec b/python-delegator-py.spec
new file mode 100644
index 0000000..64d643d
--- /dev/null
+++ b/python-delegator-py.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-delegator.py
+Version: 0.1.1
+Release: 1
+Summary: Subprocesses for Humans 2.0.
+License: MIT
+URL: https://github.com/kennethreitz/delegator
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/08/29/199c7e8efd277eb00d842cb735c65f1d3d1c070e4903b0e44b30ca8e2604/delegator.py-0.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pexpect
+
+%description
+**Delegator.py** is a simple library for dealing with subprocesses, inspired
+by both `envoy <https://github.com/kennethreitz/envoy>`_ and `pexpect <http://pexpect.readthedocs.io>`_ (in fact, it depends on it!).
+This module features two main functions ``delegator.run()`` and ``delegator.chain()``. One runs commands, blocking or non-blocking, and the other runs a chain of commands, separated by the standard unix pipe operator: ``|``.
+If you're interested in financially supporting Kenneth Reitz open source, consider `visiting this link <https://cash.me/$KennethReitz>`_. Your support helps tremendously with sustainability of motivation, as Open Source is no longer part of my day job.
+
+%package -n python3-delegator.py
+Summary: Subprocesses for Humans 2.0.
+Provides: python-delegator.py
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-delegator.py
+**Delegator.py** is a simple library for dealing with subprocesses, inspired
+by both `envoy <https://github.com/kennethreitz/envoy>`_ and `pexpect <http://pexpect.readthedocs.io>`_ (in fact, it depends on it!).
+This module features two main functions ``delegator.run()`` and ``delegator.chain()``. One runs commands, blocking or non-blocking, and the other runs a chain of commands, separated by the standard unix pipe operator: ``|``.
+If you're interested in financially supporting Kenneth Reitz open source, consider `visiting this link <https://cash.me/$KennethReitz>`_. Your support helps tremendously with sustainability of motivation, as Open Source is no longer part of my day job.
+
+%package help
+Summary: Development documents and examples for delegator.py
+Provides: python3-delegator.py-doc
+%description help
+**Delegator.py** is a simple library for dealing with subprocesses, inspired
+by both `envoy <https://github.com/kennethreitz/envoy>`_ and `pexpect <http://pexpect.readthedocs.io>`_ (in fact, it depends on it!).
+This module features two main functions ``delegator.run()`` and ``delegator.chain()``. One runs commands, blocking or non-blocking, and the other runs a chain of commands, separated by the standard unix pipe operator: ``|``.
+If you're interested in financially supporting Kenneth Reitz open source, consider `visiting this link <https://cash.me/$KennethReitz>`_. Your support helps tremendously with sustainability of motivation, as Open Source is no longer part of my day job.
+
+%prep
+%autosetup -n delegator.py-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-delegator.py -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated