summaryrefslogtreecommitdiff
path: root/python-dev-tools.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 01:19:36 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 01:19:36 +0000
commit3fb19d5615e3ea6f177f7bd663c30d76c4bd6309 (patch)
treed9d080aee12ae39c729985fee467d8002ef622f3 /python-dev-tools.spec
parentd5095745e5f19120cb947ed5db3341c6b7b7952e (diff)
automatic import of python-dev-tools
Diffstat (limited to 'python-dev-tools.spec')
-rw-r--r--python-dev-tools.spec104
1 files changed, 104 insertions, 0 deletions
diff --git a/python-dev-tools.spec b/python-dev-tools.spec
new file mode 100644
index 0000000..b995f58
--- /dev/null
+++ b/python-dev-tools.spec
@@ -0,0 +1,104 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dev-tools
+Version: 0.0.3
+Release: 1
+Summary: General dev_tools written in Python
+License: MIT
+URL: https://github.com/passer-team/dev-tools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5b/e2/ccc035e1a2ba47356135871f0851e18b71ff7e912392a02dd6ce86e986c1/dev_tools-0.0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-flask
+Requires: python3-jinja2
+
+%description
+# dev_tools
+
+使用 `Python` 编写的开发工具
+Development tools written in Python.
+
+## 模块
+
+- `passer_template_server -h` or `pts -h`, `pts` is a shortcut
+
+
+
+
+%package -n python3-dev-tools
+Summary: General dev_tools written in Python
+Provides: python-dev-tools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dev-tools
+# dev_tools
+
+使用 `Python` 编写的开发工具
+Development tools written in Python.
+
+## 模块
+
+- `passer_template_server -h` or `pts -h`, `pts` is a shortcut
+
+
+
+
+%package help
+Summary: Development documents and examples for dev-tools
+Provides: python3-dev-tools-doc
+%description help
+# dev_tools
+
+使用 `Python` 编写的开发工具
+Development tools written in Python.
+
+## 模块
+
+- `passer_template_server -h` or `pts -h`, `pts` is a shortcut
+
+
+
+
+%prep
+%autosetup -n dev-tools-0.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dev-tools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3-1
+- Package Spec generated