summaryrefslogtreecommitdiff
path: root/python-dfsql.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dfsql.spec')
-rw-r--r--python-dfsql.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-dfsql.spec b/python-dfsql.spec
new file mode 100644
index 0000000..2ecfbed
--- /dev/null
+++ b/python-dfsql.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dfsql
+Version: 0.6.8
+Release: 1
+Summary: SQL interface to Pandas
+License: GPL-3.0
+URL: https://github.com/mindsdb/dfsql
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b7/83/93c637c4d99155315718b9b5cb2a6a6062f301e958509716a9740a99261f/dfsql-0.6.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-pandas
+Requires: python3-numpy
+Requires: python3-confi
+Requires: python3-mindsdb-sql
+Requires: python3-modin[all]
+Requires: python3-pytest
+Requires: python3-requests
+Requires: python3-pytest-timeout
+
+%description
+
+
+%package -n python3-dfsql
+Summary: SQL interface to Pandas
+Provides: python-dfsql
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dfsql
+
+
+%package help
+Summary: Development documents and examples for dfsql
+Provides: python3-dfsql-doc
+%description help
+
+
+%prep
+%autosetup -n dfsql-0.6.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dfsql -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.8-1
+- Package Spec generated