summaryrefslogtreecommitdiff
path: root/python-didak.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 08:02:26 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 08:02:26 +0000
commitc653506e0c811b0e3a572f395a82ab8f93b6975d (patch)
tree88dc02b73995e3ae2117701b5008c94004a071a6 /python-didak.spec
parent55c0744c59a2e5405c23e433324e501b1827e936 (diff)
automatic import of python-didak
Diffstat (limited to 'python-didak.spec')
-rw-r--r--python-didak.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-didak.spec b/python-didak.spec
new file mode 100644
index 0000000..0800c6a
--- /dev/null
+++ b/python-didak.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-didak
+Version: 1.0.28
+Release: 1
+Summary: Didak is a simple test case runner, that simulates input and verifies the whether the final output is correct.
+License: MIT
+URL: https://github.com/rmaniego/didak
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7e/42/0ef39e704c5b72bf8a10d5fa0c8699ba727d2826af04e7e70c2596c34b88/didak-1.0.28.tar.gz
+BuildArch: noarch
+
+Requires: python3-arkivist
+Requires: python3-maguro
+Requires: python3-autopep8
+
+%description
+"Result1", "result1", "result 1"
+"Result2", "result2", "result 2"
+"Result3", "result3", "result 3"
+```
+**Sample**
+```csv
+"keyword1", "key" = "name"
+"abcde", "abc" = 23.7
+
+%package -n python3-didak
+Summary: Didak is a simple test case runner, that simulates input and verifies the whether the final output is correct.
+Provides: python-didak
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-didak
+"Result1", "result1", "result 1"
+"Result2", "result2", "result 2"
+"Result3", "result3", "result 3"
+```
+**Sample**
+```csv
+"keyword1", "key" = "name"
+"abcde", "abc" = 23.7
+
+%package help
+Summary: Development documents and examples for didak
+Provides: python3-didak-doc
+%description help
+"Result1", "result1", "result 1"
+"Result2", "result2", "result 2"
+"Result3", "result3", "result 3"
+```
+**Sample**
+```csv
+"keyword1", "key" = "name"
+"abcde", "abc" = 23.7
+
+%prep
+%autosetup -n didak-1.0.28
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-didak -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.28-1
+- Package Spec generated