summaryrefslogtreecommitdiff
path: root/python-die.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-die.spec')
-rw-r--r--python-die.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-die.spec b/python-die.spec
new file mode 100644
index 0000000..ec7e34b
--- /dev/null
+++ b/python-die.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-die
+Version: 0.2.0
+Release: 1
+Summary: Library for simulating dice, dice rolls, and stats on dice.
+License: GPL - GNU Public License
+URL: https://github.com/njharman/die
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/52/a7/c2ba9bbd846c87ff92585d48359cf66f47e1cbc9367fb46b39a5044553e1/die-0.2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-die
+Summary: Library for simulating dice, dice rolls, and stats on dice.
+Provides: python-die
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-die
+
+
+%package help
+Summary: Development documents and examples for die
+Provides: python3-die-doc
+%description help
+
+
+%prep
+%autosetup -n die-0.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-die -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
+- Package Spec generated