summaryrefslogtreecommitdiff
path: root/python-dimensigon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-dimensigon.spec')
-rw-r--r--python-dimensigon.spec172
1 files changed, 172 insertions, 0 deletions
diff --git a/python-dimensigon.spec b/python-dimensigon.spec
new file mode 100644
index 0000000..a1061a3
--- /dev/null
+++ b/python-dimensigon.spec
@@ -0,0 +1,172 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dimensigon
+Version: 0.3.5
+Release: 1
+Summary: Distributed Management and orchestration through RESTful, Mesh Networking and with a flair of IoT.
+License: GNU General Public License v3 or later (GPLv3+)
+URL: https://github.com/dimensigon/dimensigon
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/aa/e8bb12a473feeb5837f2483be160ad24188dcf9efb73ebc2c9397ef65d46/dimensigon-0.3.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-aiohttp
+Requires: python3-click
+Requires: python3-coolname
+Requires: python3-cryptography
+Requires: python3-dataclasses
+Requires: python3-dill
+Requires: python3-docopt
+Requires: python3-gunicorn
+Requires: python3-Flask
+Requires: python3-Flask-JWT-Extended
+Requires: python3-Flask-RESTFul
+Requires: python3-Flask-SQLAlchemy
+Requires: python3-jinja2
+Requires: python3-jinja2schema
+Requires: python3-jsonschema
+Requires: python3-netifaces
+Requires: python3-packaging
+Requires: python3-passlib
+Requires: python3-prompt-toolkit
+Requires: python3-Pygments
+Requires: python3-dateutil
+Requires: python3-PyYAML
+Requires: python3-requests
+Requires: python3-RestrictedPython
+Requires: python3-rsa
+Requires: python3-schema
+Requires: python3-six
+Requires: python3-watchdog
+
+%description
+**Dimensigon (DM)** is our backend technology at store.dimensigon.com to bootstrap ELASTIC Services.
+
+As main features:
+
+- Polyglot or Heterogeneous orquestrations
+- Mesh Networking
+- Decentralization of IoT or IoT 2.0 as we understand it for our own implementation.
+- Distributed-Decentralized Server Management, High-complex orchestrations
+- Full RESTful and easily embeddable
+- Distributed Vault for Configuration Management or Secrets
+- Log Federation
+- Double Encryption (SSL + Encrypted messaging by default)
+- ACLs for higher granularity and security control on top of OS Security.
+
+
+All these functionality makes **Dimensigon (DM)** a good standard for companies serving as Coordination layer for all automation technologies (Polyglot).
+**Dimensigon** (DM) lowers the costs of administration and simplify the management of high-complex environments like Hybrid Multi-Cloud.
+
+
+**Dimensigon (DM)** is a 100% Python and REAL Open Source project.
+
+**REAL Open Source** => No Freemium or Enterprise versions would be available in the future
+
+
+
+
+%package -n python3-dimensigon
+Summary: Distributed Management and orchestration through RESTful, Mesh Networking and with a flair of IoT.
+Provides: python-dimensigon
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dimensigon
+**Dimensigon (DM)** is our backend technology at store.dimensigon.com to bootstrap ELASTIC Services.
+
+As main features:
+
+- Polyglot or Heterogeneous orquestrations
+- Mesh Networking
+- Decentralization of IoT or IoT 2.0 as we understand it for our own implementation.
+- Distributed-Decentralized Server Management, High-complex orchestrations
+- Full RESTful and easily embeddable
+- Distributed Vault for Configuration Management or Secrets
+- Log Federation
+- Double Encryption (SSL + Encrypted messaging by default)
+- ACLs for higher granularity and security control on top of OS Security.
+
+
+All these functionality makes **Dimensigon (DM)** a good standard for companies serving as Coordination layer for all automation technologies (Polyglot).
+**Dimensigon** (DM) lowers the costs of administration and simplify the management of high-complex environments like Hybrid Multi-Cloud.
+
+
+**Dimensigon (DM)** is a 100% Python and REAL Open Source project.
+
+**REAL Open Source** => No Freemium or Enterprise versions would be available in the future
+
+
+
+
+%package help
+Summary: Development documents and examples for dimensigon
+Provides: python3-dimensigon-doc
+%description help
+**Dimensigon (DM)** is our backend technology at store.dimensigon.com to bootstrap ELASTIC Services.
+
+As main features:
+
+- Polyglot or Heterogeneous orquestrations
+- Mesh Networking
+- Decentralization of IoT or IoT 2.0 as we understand it for our own implementation.
+- Distributed-Decentralized Server Management, High-complex orchestrations
+- Full RESTful and easily embeddable
+- Distributed Vault for Configuration Management or Secrets
+- Log Federation
+- Double Encryption (SSL + Encrypted messaging by default)
+- ACLs for higher granularity and security control on top of OS Security.
+
+
+All these functionality makes **Dimensigon (DM)** a good standard for companies serving as Coordination layer for all automation technologies (Polyglot).
+**Dimensigon** (DM) lowers the costs of administration and simplify the management of high-complex environments like Hybrid Multi-Cloud.
+
+
+**Dimensigon (DM)** is a 100% Python and REAL Open Source project.
+
+**REAL Open Source** => No Freemium or Enterprise versions would be available in the future
+
+
+
+
+%prep
+%autosetup -n dimensigon-0.3.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dimensigon -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.5-1
+- Package Spec generated