summaryrefslogtreecommitdiff
path: root/python-django-automatic-crud.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-automatic-crud.spec')
-rw-r--r--python-django-automatic-crud.spec98
1 files changed, 98 insertions, 0 deletions
diff --git a/python-django-automatic-crud.spec b/python-django-automatic-crud.spec
new file mode 100644
index 0000000..2be29e2
--- /dev/null
+++ b/python-django-automatic-crud.spec
@@ -0,0 +1,98 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-automatic-crud
+Version: 1.2.0
+Release: 1
+Summary: CRUDS Automáticos con Django
+License: BSD License
+URL: https://github.com/developerpe/django-automatic-crud
+Source0: https://mirrors.aliyun.com/pypi/web/packages/cf/ef/0cc7130e8b4e8487254f1d5391c2dca99eb4cb5fa527d901f5d16aed38d3/django-automatic-crud-1.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+Requires: python3-openpyxl
+
+%description
+Si quieres apoyar realizando una donación, puedes hacerla a este enlace:
+- [Donación al Proyecto](https://www.paypal.com/paypalme/oliversando)
+## Redes Sociales
+[Web](http://www.developerpe.com)
+[Facebook](https://www.facebook.com/developerper​)
+[Instagram](https://www.instagram.com/developer.pe/​)
+[Twitter](https://twitter.com/Developerpepiur​)
+[Youtube](Developer.pe)
+**Correo: developerpeperu@gmail.com**
+
+%package -n python3-django-automatic-crud
+Summary: CRUDS Automáticos con Django
+Provides: python-django-automatic-crud
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-automatic-crud
+Si quieres apoyar realizando una donación, puedes hacerla a este enlace:
+- [Donación al Proyecto](https://www.paypal.com/paypalme/oliversando)
+## Redes Sociales
+[Web](http://www.developerpe.com)
+[Facebook](https://www.facebook.com/developerper​)
+[Instagram](https://www.instagram.com/developer.pe/​)
+[Twitter](https://twitter.com/Developerpepiur​)
+[Youtube](Developer.pe)
+**Correo: developerpeperu@gmail.com**
+
+%package help
+Summary: Development documents and examples for django-automatic-crud
+Provides: python3-django-automatic-crud-doc
+%description help
+Si quieres apoyar realizando una donación, puedes hacerla a este enlace:
+- [Donación al Proyecto](https://www.paypal.com/paypalme/oliversando)
+## Redes Sociales
+[Web](http://www.developerpe.com)
+[Facebook](https://www.facebook.com/developerper​)
+[Instagram](https://www.instagram.com/developer.pe/​)
+[Twitter](https://twitter.com/Developerpepiur​)
+[Youtube](Developer.pe)
+**Correo: developerpeperu@gmail.com**
+
+%prep
+%autosetup -n django-automatic-crud-1.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-automatic-crud -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.0-1
+- Package Spec generated