summaryrefslogtreecommitdiff
path: root/python-django-axes.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 15:37:52 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 15:37:52 +0000
commit0858de7d861a787d4f6a734b251d150aadb4df4e (patch)
tree7edeef003bf5b263073dc083eaf9c3524a9ed704 /python-django-axes.spec
parent2ed1314a2225dec1431faa8d2cdee83e0eba984f (diff)
automatic import of python-django-axes
Diffstat (limited to 'python-django-axes.spec')
-rw-r--r--python-django-axes.spec90
1 files changed, 90 insertions, 0 deletions
diff --git a/python-django-axes.spec b/python-django-axes.spec
new file mode 100644
index 0000000..024da88
--- /dev/null
+++ b/python-django-axes.spec
@@ -0,0 +1,90 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-axes
+Version: 5.41.0
+Release: 1
+Summary: Keep track of failed login attempts in Django-powered sites.
+License: MIT
+URL: https://github.com/jazzband/django-axes
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e8/9c/f49932498a801b9f63a3f02c5fadb0b421cfd7a4cbbfdb70251a5e783041/django-axes-5.41.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-django
+Requires: python3-django-ipware
+Requires: python3-setuptools
+
+%description
+Axes is a Django plugin for keeping track of suspicious
+login attempts for your Django based website
+and implementing simple brute-force attack blocking.
+The name is sort of a geeky pun, since it can be interpreted as:
+* ``access``, as in monitoring access attempts, or
+* ``axes``, as in tools you can use to hack (generally on wood).
+
+%package -n python3-django-axes
+Summary: Keep track of failed login attempts in Django-powered sites.
+Provides: python-django-axes
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-axes
+Axes is a Django plugin for keeping track of suspicious
+login attempts for your Django based website
+and implementing simple brute-force attack blocking.
+The name is sort of a geeky pun, since it can be interpreted as:
+* ``access``, as in monitoring access attempts, or
+* ``axes``, as in tools you can use to hack (generally on wood).
+
+%package help
+Summary: Development documents and examples for django-axes
+Provides: python3-django-axes-doc
+%description help
+Axes is a Django plugin for keeping track of suspicious
+login attempts for your Django based website
+and implementing simple brute-force attack blocking.
+The name is sort of a geeky pun, since it can be interpreted as:
+* ``access``, as in monitoring access attempts, or
+* ``axes``, as in tools you can use to hack (generally on wood).
+
+%prep
+%autosetup -n django-axes-5.41.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-axes -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 5.41.0-1
+- Package Spec generated