summaryrefslogtreecommitdiff
path: root/python-django-inbound-email.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-inbound-email.spec')
-rw-r--r--python-django-inbound-email.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/python-django-inbound-email.spec b/python-django-inbound-email.spec
new file mode 100644
index 0000000..a160865
--- /dev/null
+++ b/python-django-inbound-email.spec
@@ -0,0 +1,120 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-inbound-email
+Version: 0.13
+Release: 1
+Summary: A Django app for receiving inbound emails.
+License: MIT
+URL: https://github.com/yunojuno/django-inbound-email
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/b6/0af497573c1df515304a05c8debc64e576efe33056ef436ac921cf7eb991/django-inbound-email-0.13.tar.gz
+BuildArch: noarch
+
+
+%description
+**This package now supports Python3 and Django1.11 or above. For previous version support please refer to the Python2 branch.**
+An inbound email handler for Django.
+**Current Status**
+We have a working implementation, with SendGrid, Mailgun and Mandrill backends.
+(Both SendGrid and Mandrill have been used in production environments.)
+The test_app is deployed to Heroku and any emails sent to
+anything@django-inbound-email.yunojuno.com will be parsed by a live version of
+the test_app.
+This test app just does a bounceback - any incoming email to that address
+is sent back to the sender's address. This makes it easy to test 'real-world'
+email examples. Please feel free to send email to that address - and if you're
+using Outlook 97 on Windows XP, in China, then we'd really like to hear from
+you. You don't hear that much on Github.
+NB The app deployed on Heroku currently sends the bouncebacks using the
+Mailtrap app, so you won't actually receive the email, but I can give limited
+access to contributors so that they can see them all. I'll truncate the Mailtrap
+inbox at irregular intervals.
+
+%package -n python3-django-inbound-email
+Summary: A Django app for receiving inbound emails.
+Provides: python-django-inbound-email
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-inbound-email
+**This package now supports Python3 and Django1.11 or above. For previous version support please refer to the Python2 branch.**
+An inbound email handler for Django.
+**Current Status**
+We have a working implementation, with SendGrid, Mailgun and Mandrill backends.
+(Both SendGrid and Mandrill have been used in production environments.)
+The test_app is deployed to Heroku and any emails sent to
+anything@django-inbound-email.yunojuno.com will be parsed by a live version of
+the test_app.
+This test app just does a bounceback - any incoming email to that address
+is sent back to the sender's address. This makes it easy to test 'real-world'
+email examples. Please feel free to send email to that address - and if you're
+using Outlook 97 on Windows XP, in China, then we'd really like to hear from
+you. You don't hear that much on Github.
+NB The app deployed on Heroku currently sends the bouncebacks using the
+Mailtrap app, so you won't actually receive the email, but I can give limited
+access to contributors so that they can see them all. I'll truncate the Mailtrap
+inbox at irregular intervals.
+
+%package help
+Summary: Development documents and examples for django-inbound-email
+Provides: python3-django-inbound-email-doc
+%description help
+**This package now supports Python3 and Django1.11 or above. For previous version support please refer to the Python2 branch.**
+An inbound email handler for Django.
+**Current Status**
+We have a working implementation, with SendGrid, Mailgun and Mandrill backends.
+(Both SendGrid and Mandrill have been used in production environments.)
+The test_app is deployed to Heroku and any emails sent to
+anything@django-inbound-email.yunojuno.com will be parsed by a live version of
+the test_app.
+This test app just does a bounceback - any incoming email to that address
+is sent back to the sender's address. This makes it easy to test 'real-world'
+email examples. Please feel free to send email to that address - and if you're
+using Outlook 97 on Windows XP, in China, then we'd really like to hear from
+you. You don't hear that much on Github.
+NB The app deployed on Heroku currently sends the bouncebacks using the
+Mailtrap app, so you won't actually receive the email, but I can give limited
+access to contributors so that they can see them all. I'll truncate the Mailtrap
+inbox at irregular intervals.
+
+%prep
+%autosetup -n django-inbound-email-0.13
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-inbound-email -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.13-1
+- Package Spec generated