summaryrefslogtreecommitdiff
path: root/python-django-polymorphic.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 14:07:33 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 14:07:33 +0000
commitd8ead1a8ebeb63608b99eb0e5efe980fc29136fe (patch)
tree243270c15fdac24a0817a7946826c6cb1da1c2e2 /python-django-polymorphic.spec
parent0d6bcfa1562a36985b4d15ab227e422464bea22a (diff)
automatic import of python-django-polymorphic
Diffstat (limited to 'python-django-polymorphic.spec')
-rw-r--r--python-django-polymorphic.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-django-polymorphic.spec b/python-django-polymorphic.spec
new file mode 100644
index 0000000..6803e64
--- /dev/null
+++ b/python-django-polymorphic.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-polymorphic
+Version: 3.1.0
+Release: 1
+Summary: Seamless polymorphic inheritance for Django models
+License: BSD License
+URL: https://github.com/django-polymorphic/django-polymorphic
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/06/f43d3d7e690a6bd90c0e300d824f5aad0e9840cfd8d5bb164fd06ef6bcfc/django-polymorphic-3.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+
+%description
+Django-polymorphic simplifies using inherited models in Django projects.
+When a query is made at the base model, the inherited model classes are returned.
+When we store models that inherit from a ``Project`` model...
+ >>> Project.objects.create(topic="Department Party")
+ >>> ArtProject.objects.create(topic="Painting with Tim", artist="T. Turner")
+ >>> ResearchProject.objects.create(topic="Swallow Aerodynamics", supervisor="Dr. Winter")
+ >>> Project.objects.all()
+ [ <Project: id 1, topic "Department Party">,
+ <ArtProject: id 2, topic "Painting with Tim", artist "T. Turner">,
+ <ResearchProject: id 3, topic "Swallow Aerodynamics", supervisor "Dr. Winter"> ]
+Using vanilla Django, we get the base class objects, which is rarely what we wanted:
+ >>> Project.objects.all()
+ [ <Project: id 1, topic "Department Party">,
+ <Project: id 2, topic "Painting with Tim">,
+ <Project: id 3, topic "Swallow Aerodynamics"> ]
+This also works when the polymorphic model is accessed via
+ForeignKeys, ManyToManyFields or OneToOneFields.
+
+%package -n python3-django-polymorphic
+Summary: Seamless polymorphic inheritance for Django models
+Provides: python-django-polymorphic
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-polymorphic
+Django-polymorphic simplifies using inherited models in Django projects.
+When a query is made at the base model, the inherited model classes are returned.
+When we store models that inherit from a ``Project`` model...
+ >>> Project.objects.create(topic="Department Party")
+ >>> ArtProject.objects.create(topic="Painting with Tim", artist="T. Turner")
+ >>> ResearchProject.objects.create(topic="Swallow Aerodynamics", supervisor="Dr. Winter")
+ >>> Project.objects.all()
+ [ <Project: id 1, topic "Department Party">,
+ <ArtProject: id 2, topic "Painting with Tim", artist "T. Turner">,
+ <ResearchProject: id 3, topic "Swallow Aerodynamics", supervisor "Dr. Winter"> ]
+Using vanilla Django, we get the base class objects, which is rarely what we wanted:
+ >>> Project.objects.all()
+ [ <Project: id 1, topic "Department Party">,
+ <Project: id 2, topic "Painting with Tim">,
+ <Project: id 3, topic "Swallow Aerodynamics"> ]
+This also works when the polymorphic model is accessed via
+ForeignKeys, ManyToManyFields or OneToOneFields.
+
+%package help
+Summary: Development documents and examples for django-polymorphic
+Provides: python3-django-polymorphic-doc
+%description help
+Django-polymorphic simplifies using inherited models in Django projects.
+When a query is made at the base model, the inherited model classes are returned.
+When we store models that inherit from a ``Project`` model...
+ >>> Project.objects.create(topic="Department Party")
+ >>> ArtProject.objects.create(topic="Painting with Tim", artist="T. Turner")
+ >>> ResearchProject.objects.create(topic="Swallow Aerodynamics", supervisor="Dr. Winter")
+ >>> Project.objects.all()
+ [ <Project: id 1, topic "Department Party">,
+ <ArtProject: id 2, topic "Painting with Tim", artist "T. Turner">,
+ <ResearchProject: id 3, topic "Swallow Aerodynamics", supervisor "Dr. Winter"> ]
+Using vanilla Django, we get the base class objects, which is rarely what we wanted:
+ >>> Project.objects.all()
+ [ <Project: id 1, topic "Department Party">,
+ <Project: id 2, topic "Painting with Tim">,
+ <Project: id 3, topic "Swallow Aerodynamics"> ]
+This also works when the polymorphic model is accessed via
+ForeignKeys, ManyToManyFields or OneToOneFields.
+
+%prep
+%autosetup -n django-polymorphic-3.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-polymorphic -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
+- Package Spec generated