summaryrefslogtreecommitdiff
path: root/python-django-qrcode.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-qrcode.spec')
-rw-r--r--python-django-qrcode.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-django-qrcode.spec b/python-django-qrcode.spec
new file mode 100644
index 0000000..99a61e2
--- /dev/null
+++ b/python-django-qrcode.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-qrcode
+Version: 0.3
+Release: 1
+Summary: Django application that provides simple templatetags to generate QR-codes
+License: LGPL 3
+URL: https://github.com/zocolab/django-qrcode
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/2f/4263fba93ae6a46776d6a8359ff1e192f38dffcc6f2925d29463375254fa/django-qrcode-0.3.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-django-qrcode
+Summary: Django application that provides simple templatetags to generate QR-codes
+Provides: python-django-qrcode
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-qrcode
+
+
+%package help
+Summary: Development documents and examples for django-qrcode
+Provides: python3-django-qrcode-doc
+%description help
+
+
+%prep
+%autosetup -n django-qrcode-0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-qrcode -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3-1
+- Package Spec generated