summaryrefslogtreecommitdiff
path: root/python-django-redis.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-09 07:09:05 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-09 07:09:05 +0000
commit096c317d8114bf95e1ce3b069161338c9700dfdf (patch)
tree96de47b25a886f9e3a2c9d338ba82d18ac60f2db /python-django-redis.spec
parent8c0fb42ff6138bfddde73ff4b8e2ecb95325ba2c (diff)
automatic import of python-django-redis
Diffstat (limited to 'python-django-redis.spec')
-rw-r--r--python-django-redis.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-django-redis.spec b/python-django-redis.spec
new file mode 100644
index 0000000..14355ab
--- /dev/null
+++ b/python-django-redis.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-redis
+Version: 5.2.0
+Release: 1
+Summary: Full featured redis cache backend for Django.
+License: BSD-3-Clause
+URL: https://github.com/jazzband/django-redis
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1b/9d/e4f6b6974f602b6c2dd08694b66cd3b30ca75640d185a566d0c075e4b71f/django-redis-5.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+Requires: python3-redis
+Requires: python3-redis[hiredis]
+
+%description
+
+
+%package -n python3-django-redis
+Summary: Full featured redis cache backend for Django.
+Provides: python-django-redis
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-redis
+
+
+%package help
+Summary: Development documents and examples for django-redis
+Provides: python3-django-redis-doc
+%description help
+
+
+%prep
+%autosetup -n django-redis-5.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-redis -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 5.2.0-1
+- Package Spec generated