summaryrefslogtreecommitdiff
path: root/python-django-social-share.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-social-share.spec')
-rw-r--r--python-django-social-share.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-django-social-share.spec b/python-django-social-share.spec
new file mode 100644
index 0000000..c4fe2be
--- /dev/null
+++ b/python-django-social-share.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-social-share
+Version: 2.3.0
+Release: 1
+Summary: Templatetags for 'tweet this' and 'share on facebook'
+License: MIT
+URL: https://github.com/fcurella/django-social-share
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/06/82/5bb1e496a85b00fdcc0f6220a73d670d0c7a722424a689d370f51c0cf3c9/django-social-share-2.3.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Provides templatetags for:
+* 'Tweet This'
+* 'Share this on Facebook'
+* 'Share on Google+'
+* 'Share on LinkedIn'
+* 'Share on Telegram'
+* 'Share on WhatsApp'
+* 'mailto://'.
+* 'Save to Pinterest'
+* 'Copy to Clipboard'
+Plain HTML templates_ are provided for your convenience, but you can override them to provide your own look and feel.
+
+%package -n python3-django-social-share
+Summary: Templatetags for 'tweet this' and 'share on facebook'
+Provides: python-django-social-share
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-social-share
+Provides templatetags for:
+* 'Tweet This'
+* 'Share this on Facebook'
+* 'Share on Google+'
+* 'Share on LinkedIn'
+* 'Share on Telegram'
+* 'Share on WhatsApp'
+* 'mailto://'.
+* 'Save to Pinterest'
+* 'Copy to Clipboard'
+Plain HTML templates_ are provided for your convenience, but you can override them to provide your own look and feel.
+
+%package help
+Summary: Development documents and examples for django-social-share
+Provides: python3-django-social-share-doc
+%description help
+Provides templatetags for:
+* 'Tweet This'
+* 'Share this on Facebook'
+* 'Share on Google+'
+* 'Share on LinkedIn'
+* 'Share on Telegram'
+* 'Share on WhatsApp'
+* 'mailto://'.
+* 'Save to Pinterest'
+* 'Copy to Clipboard'
+Plain HTML templates_ are provided for your convenience, but you can override them to provide your own look and feel.
+
+%prep
+%autosetup -n django-social-share-2.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-social-share -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.0-1
+- Package Spec generated