summaryrefslogtreecommitdiff
path: root/python-django-sudo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 04:43:40 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 04:43:40 +0000
commit0ca39f59732ec5c7af2b8e14bd3485c35ef2cb8c (patch)
treeb0f5a853f9faa436e63db1f6bf67b7aa99a51b87 /python-django-sudo.spec
parentbd053526db4cf5bda3cf13a6fa61bb4bf97cc587 (diff)
automatic import of python-django-sudo
Diffstat (limited to 'python-django-sudo.spec')
-rw-r--r--python-django-sudo.spec171
1 files changed, 171 insertions, 0 deletions
diff --git a/python-django-sudo.spec b/python-django-sudo.spec
new file mode 100644
index 0000000..e79890a
--- /dev/null
+++ b/python-django-sudo.spec
@@ -0,0 +1,171 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-sudo
+Version: 3.1.0
+Release: 1
+Summary: Extra security for your sensitive pages
+License: BSD
+URL: https://github.com/mattrobenolt/django-sudo
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ca/63/9ad066bf7f9c3193fb1d9b8d8d926400acc32ea8d140fb27018bff5587b4/django-sudo-3.1.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# django-sudo
+
+[![](https://travis-ci.org/mattrobenolt/django-sudo.svg?branch=master)](https://travis-ci.org/mattrobenolt/django-sudo) [![](https://coveralls.io/repos/mattrobenolt/django-sudo/badge.png?branch=master)](https://coveralls.io/r/mattrobenolt/django-sudo?branch=master)
+
+> Sudo mode is an extra layer of security for your most sensitive pages.<br>
+> This is an implementation of GitHub's [Sudo Mode](https://github.com/blog/1513-introducing-github-sudo-mode) for [Django](https://www.djangoproject.com/).
+
+## What is this for?
+
+`django-sudo` provides an extra layer of security for after a user is already logged in. Views can
+be decorated with `@sudo_required`, and then a user
+must re-enter their password to view that page. After verifying their password, that user has
+elevated permissions for the duration of `SUDO_COOKIE_AGE`. This duration is independent of the
+normal session duration allowing short elevated permission durations, but retain long user sessions.
+
+## Installation
+
+```console
+$ pip install django-sudo
+```
+
+## Compatibility
+
+* Django 1.9-1.11
+* Python 2.7, 3.6-3.7
+
+## Resources
+
+* [Documentation](https://django-sudo.readthedocs.io/)
+* [Security](https://django-sudo.readthedocs.io/en/latest/security/index.html)
+* [Changelog](https://django-sudo.readthedocs.io/en/latest/changelog/index.html)
+
+
+
+
+%package -n python3-django-sudo
+Summary: Extra security for your sensitive pages
+Provides: python-django-sudo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-sudo
+# django-sudo
+
+[![](https://travis-ci.org/mattrobenolt/django-sudo.svg?branch=master)](https://travis-ci.org/mattrobenolt/django-sudo) [![](https://coveralls.io/repos/mattrobenolt/django-sudo/badge.png?branch=master)](https://coveralls.io/r/mattrobenolt/django-sudo?branch=master)
+
+> Sudo mode is an extra layer of security for your most sensitive pages.<br>
+> This is an implementation of GitHub's [Sudo Mode](https://github.com/blog/1513-introducing-github-sudo-mode) for [Django](https://www.djangoproject.com/).
+
+## What is this for?
+
+`django-sudo` provides an extra layer of security for after a user is already logged in. Views can
+be decorated with `@sudo_required`, and then a user
+must re-enter their password to view that page. After verifying their password, that user has
+elevated permissions for the duration of `SUDO_COOKIE_AGE`. This duration is independent of the
+normal session duration allowing short elevated permission durations, but retain long user sessions.
+
+## Installation
+
+```console
+$ pip install django-sudo
+```
+
+## Compatibility
+
+* Django 1.9-1.11
+* Python 2.7, 3.6-3.7
+
+## Resources
+
+* [Documentation](https://django-sudo.readthedocs.io/)
+* [Security](https://django-sudo.readthedocs.io/en/latest/security/index.html)
+* [Changelog](https://django-sudo.readthedocs.io/en/latest/changelog/index.html)
+
+
+
+
+%package help
+Summary: Development documents and examples for django-sudo
+Provides: python3-django-sudo-doc
+%description help
+# django-sudo
+
+[![](https://travis-ci.org/mattrobenolt/django-sudo.svg?branch=master)](https://travis-ci.org/mattrobenolt/django-sudo) [![](https://coveralls.io/repos/mattrobenolt/django-sudo/badge.png?branch=master)](https://coveralls.io/r/mattrobenolt/django-sudo?branch=master)
+
+> Sudo mode is an extra layer of security for your most sensitive pages.<br>
+> This is an implementation of GitHub's [Sudo Mode](https://github.com/blog/1513-introducing-github-sudo-mode) for [Django](https://www.djangoproject.com/).
+
+## What is this for?
+
+`django-sudo` provides an extra layer of security for after a user is already logged in. Views can
+be decorated with `@sudo_required`, and then a user
+must re-enter their password to view that page. After verifying their password, that user has
+elevated permissions for the duration of `SUDO_COOKIE_AGE`. This duration is independent of the
+normal session duration allowing short elevated permission durations, but retain long user sessions.
+
+## Installation
+
+```console
+$ pip install django-sudo
+```
+
+## Compatibility
+
+* Django 1.9-1.11
+* Python 2.7, 3.6-3.7
+
+## Resources
+
+* [Documentation](https://django-sudo.readthedocs.io/)
+* [Security](https://django-sudo.readthedocs.io/en/latest/security/index.html)
+* [Changelog](https://django-sudo.readthedocs.io/en/latest/changelog/index.html)
+
+
+
+
+%prep
+%autosetup -n django-sudo-3.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-sudo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
+- Package Spec generated