summaryrefslogtreecommitdiff
path: root/python-django-user-agents.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-user-agents.spec')
-rw-r--r--python-django-user-agents.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-django-user-agents.spec b/python-django-user-agents.spec
new file mode 100644
index 0000000..f6de7c2
--- /dev/null
+++ b/python-django-user-agents.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-user-agents
+Version: 0.4.0
+Release: 1
+Summary: A django package that allows easy identification of visitors' browser, operating system and device information (mobile phone, tablet or has touch capabilities).
+License: MIT
+URL: https://github.com/selwin/django-user_agents
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/37/f2/dd96cc880d7549cc9f67c8b1ad8e6695f9731658fdf8aa476f0bcb9c89c7/django-user_agents-0.4.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-django
+Requires: python3-user-agents
+
+%description
+A django package that allows easy identification of visitor's browser, OS and device information,
+including whether the visitor uses a mobile phone, tablet or a touch capable device. Under the hood,
+it uses `user-agents <https://github.com/selwin/python-user-agents>`_.
+
+%package -n python3-django-user-agents
+Summary: A django package that allows easy identification of visitors' browser, operating system and device information (mobile phone, tablet or has touch capabilities).
+Provides: python-django-user-agents
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-user-agents
+A django package that allows easy identification of visitor's browser, OS and device information,
+including whether the visitor uses a mobile phone, tablet or a touch capable device. Under the hood,
+it uses `user-agents <https://github.com/selwin/python-user-agents>`_.
+
+%package help
+Summary: Development documents and examples for django-user-agents
+Provides: python3-django-user-agents-doc
+%description help
+A django package that allows easy identification of visitor's browser, OS and device information,
+including whether the visitor uses a mobile phone, tablet or a touch capable device. Under the hood,
+it uses `user-agents <https://github.com/selwin/python-user-agents>`_.
+
+%prep
+%autosetup -n django-user-agents-0.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-user-agents -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.0-1
+- Package Spec generated