summaryrefslogtreecommitdiff
path: root/python-django-user-tasks.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-user-tasks.spec')
-rw-r--r--python-django-user-tasks.spec118
1 files changed, 118 insertions, 0 deletions
diff --git a/python-django-user-tasks.spec b/python-django-user-tasks.spec
new file mode 100644
index 0000000..05ecb71
--- /dev/null
+++ b/python-django-user-tasks.spec
@@ -0,0 +1,118 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-user-tasks
+Version: 3.0.0
+Release: 1
+Summary: Management of user-triggered asynchronous tasks in Django projects
+License: Apache Software License 2.0
+URL: https://github.com/edx/django-user-tasks
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f4/aa/aa169f5ad87abdf8f2722599495e156c31ec512c50003a9fedf1e94ade91/django-user-tasks-3.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+Requires: python3-celery
+Requires: python3-django-model-utils
+Requires: python3-djangorestframework
+
+%description
+django-user-tasks is a reusable Django application for managing user-triggered
+asynchronous tasks. It provides a status page for each such task, which
+includes a meaningful progress indicator if the task is currently being
+executed and provides any appropriate text and/or links for output once the
+task is complete.
+In Open edX, such tasks include operations such as exporting or importing a
+course, sending an email to all the students in a course, uploading a video,
+and other tasks which often take too long to perform during a single web
+request (as outlined in `OEP-3`_). However, this has been written with the
+intention of being useful in a variety of Django projects outside the Open edX
+platform as well.
+Note that this library was created as a consolidation of lessons learned from
+implementing such tasks in various parts of the Open edX code base. They
+don't yet all use this library, but the plan is to over time refactor many of
+them to do so.
+
+%package -n python3-django-user-tasks
+Summary: Management of user-triggered asynchronous tasks in Django projects
+Provides: python-django-user-tasks
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-user-tasks
+django-user-tasks is a reusable Django application for managing user-triggered
+asynchronous tasks. It provides a status page for each such task, which
+includes a meaningful progress indicator if the task is currently being
+executed and provides any appropriate text and/or links for output once the
+task is complete.
+In Open edX, such tasks include operations such as exporting or importing a
+course, sending an email to all the students in a course, uploading a video,
+and other tasks which often take too long to perform during a single web
+request (as outlined in `OEP-3`_). However, this has been written with the
+intention of being useful in a variety of Django projects outside the Open edX
+platform as well.
+Note that this library was created as a consolidation of lessons learned from
+implementing such tasks in various parts of the Open edX code base. They
+don't yet all use this library, but the plan is to over time refactor many of
+them to do so.
+
+%package help
+Summary: Development documents and examples for django-user-tasks
+Provides: python3-django-user-tasks-doc
+%description help
+django-user-tasks is a reusable Django application for managing user-triggered
+asynchronous tasks. It provides a status page for each such task, which
+includes a meaningful progress indicator if the task is currently being
+executed and provides any appropriate text and/or links for output once the
+task is complete.
+In Open edX, such tasks include operations such as exporting or importing a
+course, sending an email to all the students in a course, uploading a video,
+and other tasks which often take too long to perform during a single web
+request (as outlined in `OEP-3`_). However, this has been written with the
+intention of being useful in a variety of Django projects outside the Open edX
+platform as well.
+Note that this library was created as a consolidation of lessons learned from
+implementing such tasks in various parts of the Open edX code base. They
+don't yet all use this library, but the plan is to over time refactor many of
+them to do so.
+
+%prep
+%autosetup -n django-user-tasks-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-user-tasks -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated