summaryrefslogtreecommitdiff
path: root/python-django-watson.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-django-watson.spec')
-rw-r--r--python-django-watson.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-django-watson.spec b/python-django-watson.spec
new file mode 100644
index 0000000..facc060
--- /dev/null
+++ b/python-django-watson.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-django-watson
+Version: 1.6.3
+Release: 1
+Summary: Full-text multi-table search application for Django. Easy to install and use, with good performance.
+License: BSD License
+URL: http://github.com/etianen/django-watson
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/43/a9/f84a7c9691796cb4eab67405e2fd624415f7acd43bd0f04a742c7a4fb81e/django-watson-1.6.3.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Django CI](https://github.com/etianen/django-watson/actions/workflows/django.yml/badge.svg)](https://github.com/etianen/django-watson/actions/workflows/django.yml)
+[![PyPI](https://img.shields.io/pypi/v/django-watson.svg)](https://pypi.python.org/pypi/django-watson)
+[![GitHub license](https://img.shields.io/badge/license-New%20BSD-blue.svg)](https://raw.githubusercontent.com/etianen/django-watson/master/LICENSE)
+**django-watson** is a fast multi-model full-text search plugin for Django.
+It is easy to install and use, and provides high quality search results.
+
+%package -n python3-django-watson
+Summary: Full-text multi-table search application for Django. Easy to install and use, with good performance.
+Provides: python-django-watson
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-django-watson
+[![Django CI](https://github.com/etianen/django-watson/actions/workflows/django.yml/badge.svg)](https://github.com/etianen/django-watson/actions/workflows/django.yml)
+[![PyPI](https://img.shields.io/pypi/v/django-watson.svg)](https://pypi.python.org/pypi/django-watson)
+[![GitHub license](https://img.shields.io/badge/license-New%20BSD-blue.svg)](https://raw.githubusercontent.com/etianen/django-watson/master/LICENSE)
+**django-watson** is a fast multi-model full-text search plugin for Django.
+It is easy to install and use, and provides high quality search results.
+
+%package help
+Summary: Development documents and examples for django-watson
+Provides: python3-django-watson-doc
+%description help
+[![Django CI](https://github.com/etianen/django-watson/actions/workflows/django.yml/badge.svg)](https://github.com/etianen/django-watson/actions/workflows/django.yml)
+[![PyPI](https://img.shields.io/pypi/v/django-watson.svg)](https://pypi.python.org/pypi/django-watson)
+[![GitHub license](https://img.shields.io/badge/license-New%20BSD-blue.svg)](https://raw.githubusercontent.com/etianen/django-watson/master/LICENSE)
+**django-watson** is a fast multi-model full-text search plugin for Django.
+It is easy to install and use, and provides high quality search results.
+
+%prep
+%autosetup -n django-watson-1.6.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-django-watson -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.3-1
+- Package Spec generated