summaryrefslogtreecommitdiff
path: root/python-djangoql.spec
diff options
context:
space:
mode:
authorCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-09 07:12:47 +0000
committerCoprDistGit <copr-devel@lists.fedorahosted.org>2023-03-09 07:12:47 +0000
commit03b45af627f953fedcfd03c92091f91faa9751e1 (patch)
tree8c856606cb871383284ecb6d79350d850ff09099 /python-djangoql.spec
parent942547c2c9cf7a3b467f309a4c6fb1c90726c040 (diff)
automatic import of python-djangoql
Diffstat (limited to 'python-djangoql.spec')
-rw-r--r--python-djangoql.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-djangoql.spec b/python-djangoql.spec
new file mode 100644
index 0000000..0af7a20
--- /dev/null
+++ b/python-djangoql.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-djangoql
+Version: 0.17.1
+Release: 1
+Summary: DjangoQL: Advanced search language for Django
+License: MIT License
+URL: https://github.com/ivelum/djangoql/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/00/80/548c8f4947869880f96aa4157abe3b94ebde7ae59c846245757d217d2fe3/djangoql-0.17.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Advanced search language for Django, with auto-completion. Supports logical
+operators, parenthesis, table joins, and works with any Django model. Tested on
+Python 2.7, 3.5 - 3.10, Django 1.8 - 4.0. The auto-completion feature has been
+tested in Chrome, Firefox, Safari, IE9+.
+See a video: `DjangoQL demo <https://youtu.be/oKVff4dHZB8>`_
+DjangoQL is used by:
+|logo1| |logo2| |logo3| |logo4|
+Is your project using DjangoQL? Please submit a PR and let us know!
+
+%package -n python3-djangoql
+Summary: DjangoQL: Advanced search language for Django
+Provides: python-djangoql
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-djangoql
+Advanced search language for Django, with auto-completion. Supports logical
+operators, parenthesis, table joins, and works with any Django model. Tested on
+Python 2.7, 3.5 - 3.10, Django 1.8 - 4.0. The auto-completion feature has been
+tested in Chrome, Firefox, Safari, IE9+.
+See a video: `DjangoQL demo <https://youtu.be/oKVff4dHZB8>`_
+DjangoQL is used by:
+|logo1| |logo2| |logo3| |logo4|
+Is your project using DjangoQL? Please submit a PR and let us know!
+
+%package help
+Summary: Development documents and examples for djangoql
+Provides: python3-djangoql-doc
+%description help
+Advanced search language for Django, with auto-completion. Supports logical
+operators, parenthesis, table joins, and works with any Django model. Tested on
+Python 2.7, 3.5 - 3.10, Django 1.8 - 4.0. The auto-completion feature has been
+tested in Chrome, Firefox, Safari, IE9+.
+See a video: `DjangoQL demo <https://youtu.be/oKVff4dHZB8>`_
+DjangoQL is used by:
+|logo1| |logo2| |logo3| |logo4|
+Is your project using DjangoQL? Please submit a PR and let us know!
+
+%prep
+%autosetup -n djangoql-0.17.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-djangoql -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.17.1-1
+- Package Spec generated