summaryrefslogtreecommitdiff
path: root/python-djfirebirdsql.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-djfirebirdsql.spec')
-rw-r--r--python-djfirebirdsql.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-djfirebirdsql.spec b/python-djfirebirdsql.spec
new file mode 100644
index 0000000..16bb839
--- /dev/null
+++ b/python-djfirebirdsql.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-djfirebirdsql
+Version: 0.3.0
+Release: 1
+Summary: Django database backend for firebird
+License: BSD
+URL: https://github.com/nakagami/djfirebirdsql/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/99/45/7ddca8f8ba6914f54796df897a283534f185edf15614515c5f11d0ab1216/djfirebirdsql-0.3.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Django firebird https://firebirdsql.org/ database backend.
+I referrerd django-firebird database backend https://github.com/maxirobaina/django-firebird .
+
+%package -n python3-djfirebirdsql
+Summary: Django database backend for firebird
+Provides: python-djfirebirdsql
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-djfirebirdsql
+Django firebird https://firebirdsql.org/ database backend.
+I referrerd django-firebird database backend https://github.com/maxirobaina/django-firebird .
+
+%package help
+Summary: Development documents and examples for djfirebirdsql
+Provides: python3-djfirebirdsql-doc
+%description help
+Django firebird https://firebirdsql.org/ database backend.
+I referrerd django-firebird database backend https://github.com/maxirobaina/django-firebird .
+
+%prep
+%autosetup -n djfirebirdsql-0.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-djfirebirdsql -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
+- Package Spec generated