summaryrefslogtreecommitdiff
path: root/python-dm-control.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 11:13:15 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 11:13:15 +0000
commit2d9b569b0acc69f90f27a9e982118f7a8da8b9cf (patch)
treef3287344cc345970a56fc592a54f7420b3fdbee2 /python-dm-control.spec
parent874d39076c9f6d93d62507fec3905f49d979ce2c (diff)
automatic import of python-dm-controlopeneuler20.03
Diffstat (limited to 'python-dm-control.spec')
-rw-r--r--python-dm-control.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/python-dm-control.spec b/python-dm-control.spec
new file mode 100644
index 0000000..b5df490
--- /dev/null
+++ b/python-dm-control.spec
@@ -0,0 +1,112 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dm-control
+Version: 1.0.12
+Release: 1
+Summary: Continuous control environments and MuJoCo Python bindings.
+License: Apache License 2.0
+URL: https://github.com/deepmind/dm_control
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/6b/dd/851022971997f7d064cbd4daa8f834ec48cb5e7728021a128821321934c6/dm_control-1.0.12.tar.gz
+BuildArch: noarch
+
+Requires: python3-absl-py
+Requires: python3-dm-env
+Requires: python3-dm-tree
+Requires: python3-glfw
+Requires: python3-labmaze
+Requires: python3-lxml
+Requires: python3-mujoco
+Requires: python3-numpy
+Requires: python3-protobuf
+Requires: python3-pyopengl
+Requires: python3-pyparsing
+Requires: python3-requests
+Requires: python3-setuptools
+Requires: python3-scipy
+Requires: python3-tqdm
+Requires: python3-h5py
+
+%description
+
+# `dm_control`: DeepMind Infrastructure for Physics-Based Simulation.
+
+DeepMind's software stack for physics-based simulation and Reinforcement
+Learning environments, using MuJoCo physics.
+
+An **introductory tutorial** for this package is available as a Colaboratory
+notebook: [Open In Google Colab](https://colab.research.google.com/github/deepmind/dm_control/blob/main/tutorial.ipynb).
+
+
+%package -n python3-dm-control
+Summary: Continuous control environments and MuJoCo Python bindings.
+Provides: python-dm-control
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dm-control
+
+# `dm_control`: DeepMind Infrastructure for Physics-Based Simulation.
+
+DeepMind's software stack for physics-based simulation and Reinforcement
+Learning environments, using MuJoCo physics.
+
+An **introductory tutorial** for this package is available as a Colaboratory
+notebook: [Open In Google Colab](https://colab.research.google.com/github/deepmind/dm_control/blob/main/tutorial.ipynb).
+
+
+%package help
+Summary: Development documents and examples for dm-control
+Provides: python3-dm-control-doc
+%description help
+
+# `dm_control`: DeepMind Infrastructure for Physics-Based Simulation.
+
+DeepMind's software stack for physics-based simulation and Reinforcement
+Learning environments, using MuJoCo physics.
+
+An **introductory tutorial** for this package is available as a Colaboratory
+notebook: [Open In Google Colab](https://colab.research.google.com/github/deepmind/dm_control/blob/main/tutorial.ipynb).
+
+
+%prep
+%autosetup -n dm-control-1.0.12
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dm-control -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.12-1
+- Package Spec generated