summaryrefslogtreecommitdiff
path: root/python-dmit.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 03:45:33 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 03:45:33 +0000
commit3972b43593d513ad7c3e306df8e4a6f6662090de (patch)
tree1a959d4f1c558cfb1b2b0fd2113a4b953042ccd0 /python-dmit.spec
parent6ec9bb51f7b3e513bedf30d55667611773175d61 (diff)
automatic import of python-dmit
Diffstat (limited to 'python-dmit.spec')
-rw-r--r--python-dmit.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-dmit.spec b/python-dmit.spec
new file mode 100644
index 0000000..07c452b
--- /dev/null
+++ b/python-dmit.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dmit
+Version: 0.5.1
+Release: 1
+Summary: A Met Tool package
+License: MIT License
+URL: https://pypi.org/project/dmit/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f7/ba/9f597502c8856905b3315e097f24487fde914a866531af69a8d62e607da8/dmit-0.5.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-wheel
+Requires: python3-scipy
+Requires: python3-numpy
+Requires: python3-boto3
+
+%description
+#DMIMET
+Tools commonly used in Meteorological software that I dont want to replicate all the times
+
+#Documentation:
+https://dmit.readthedocs.io/en/latest/
+
+### Docstrings
+For the sake of making the documentation as automatic as possible the standard of numpy docstring is followed.
+https://numpydoc.readthedocs.io/en/latest/format.html#docstring-standard
+This is supported also by sphinx.
+
+The docs is made with sphinx and can be found here:
+https://dmit.readthedocs.io/en/latest/
+
+
+
+
+%package -n python3-dmit
+Summary: A Met Tool package
+Provides: python-dmit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dmit
+#DMIMET
+Tools commonly used in Meteorological software that I dont want to replicate all the times
+
+#Documentation:
+https://dmit.readthedocs.io/en/latest/
+
+### Docstrings
+For the sake of making the documentation as automatic as possible the standard of numpy docstring is followed.
+https://numpydoc.readthedocs.io/en/latest/format.html#docstring-standard
+This is supported also by sphinx.
+
+The docs is made with sphinx and can be found here:
+https://dmit.readthedocs.io/en/latest/
+
+
+
+
+%package help
+Summary: Development documents and examples for dmit
+Provides: python3-dmit-doc
+%description help
+#DMIMET
+Tools commonly used in Meteorological software that I dont want to replicate all the times
+
+#Documentation:
+https://dmit.readthedocs.io/en/latest/
+
+### Docstrings
+For the sake of making the documentation as automatic as possible the standard of numpy docstring is followed.
+https://numpydoc.readthedocs.io/en/latest/format.html#docstring-standard
+This is supported also by sphinx.
+
+The docs is made with sphinx and can be found here:
+https://dmit.readthedocs.io/en/latest/
+
+
+
+
+%prep
+%autosetup -n dmit-0.5.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dmit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.1-1
+- Package Spec generated