summaryrefslogtreecommitdiff
path: root/python-dnsdiag.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 19:55:21 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 19:55:21 +0000
commit302729d8e2998df874da162e60675b8443b60b85 (patch)
treefe4e3aef31660344fc85d85d55228cc93804304c /python-dnsdiag.spec
parent4ffb7522eb461d3270617da0513fac7637edc003 (diff)
automatic import of python-dnsdiag
Diffstat (limited to 'python-dnsdiag.spec')
-rw-r--r--python-dnsdiag.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-dnsdiag.spec b/python-dnsdiag.spec
new file mode 100644
index 0000000..4134243
--- /dev/null
+++ b/python-dnsdiag.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-dnsdiag
+Version: 2.1.0
+Release: 1
+Summary: DNS Measurement, Troubleshooting and Security Auditing Toolset (ping, traceroute)
+License: BSD
+URL: https://dnsdiag.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/07/5f/af347f5443e4b9087a720da145347126d450392bcc3ee474f415149e7fff/dnsdiag-2.1.0.tar.gz
+BuildArch: noarch
+
+
+%description
+
+DNSDiag provides a handful of tools to measure and diagnose your DNS
+performance and integrity. Using dnsping, dnstraceroute and dnseval tools
+you can measure your DNS response quality from delay and loss perspective
+as well as tracing the path your DNS query takes to get to DNS server.
+
+
+%package -n python3-dnsdiag
+Summary: DNS Measurement, Troubleshooting and Security Auditing Toolset (ping, traceroute)
+Provides: python-dnsdiag
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-dnsdiag
+
+DNSDiag provides a handful of tools to measure and diagnose your DNS
+performance and integrity. Using dnsping, dnstraceroute and dnseval tools
+you can measure your DNS response quality from delay and loss perspective
+as well as tracing the path your DNS query takes to get to DNS server.
+
+
+%package help
+Summary: Development documents and examples for dnsdiag
+Provides: python3-dnsdiag-doc
+%description help
+
+DNSDiag provides a handful of tools to measure and diagnose your DNS
+performance and integrity. Using dnsping, dnstraceroute and dnseval tools
+you can measure your DNS response quality from delay and loss perspective
+as well as tracing the path your DNS query takes to get to DNS server.
+
+
+%prep
+%autosetup -n dnsdiag-2.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-dnsdiag -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
+- Package Spec generated